Bug 479582 - Gnubversion doesn't work on F10 and Rawhide
Gnubversion doesn't work on F10 and Rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnubversion (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-11 12:49 EST by Erik van Pienbroek
Modified: 2009-03-02 04:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 04:11:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik van Pienbroek 2009-01-11 12:49:14 EST
I just tried to install gnubversion on a 32bit F10 and a 64bit Rawhide machine. On both environments, gnubversion doesn't work. I expect to see some additional options when I browse to a Subversion checkout folder with Nautilus ( as can be seen at http://sourceforge.net/project/screenshots.php?group_id=208507&ssid=74692 ). However, these options don't show up. I suspect this is because the Nautilus plugin is installed in %{_libdir}/nautilus/extensions-1.0/ while other Nautilus plugins are installed in %{_libdir}/nautilus/extensions-2.0/

Another issue I've found with this package is that some images are wrongly symlinked:

$ gvn-update

** (gvn-update:1188): DEBUG: Username: 

(gvn-update:1188): libglade-WARNING **: Error loading image: Failed to open file '/usr/share/gnubversion/gvn-update.png': Too many levels of symbolic links

(gvn-update:1188): libglade-WARNING **: could not convert string to type `GdkPixbuf' for property `pixbuf'

$ ls -al /usr/share/gnubversion
total 316
drwxr-xr-x   2 root root  4096 Jan  9 23:20 .
drwxr-xr-x 436 root root 12288 Jan 11 13:55 ..
-rw-r--r--   1 root root 37172 Jan  8 12:55 about.glade
-rw-r--r--   1 root root  4172 Jan  8 12:55 commonOptions.glade
-rw-r--r--   1 root root  6972 Jan  8 12:55 fileSelector.glade
-rw-r--r--   1 root root 32305 Jan  8 12:55 gnubversion-logo.svg
-rw-r--r--   1 root root 22300 Jan  8 12:55 gvn-add.glade
lrwxrwxrwx   1 root root    11 Jan  9 23:20 gvn-add.png -> gvn-add.png
-rw-r--r--   1 root root 35241 Jan  8 12:55 gvn-checkout.glade
-rw-r--r--   1 root root 21600 Jan  8 12:55 gvn-commit.glade
lrwxrwxrwx   1 root root    14 Jan  9 23:20 gvn-commit.png -> gvn-commit.png
-rw-r--r--   1 root root 20164 Jan  8 12:55 gvn-remove.glade
lrwxrwxrwx   1 root root    14 Jan  9 23:20 gvn-remove.png -> gvn-remove.png
-rw-r--r--   1 root root 20110 Jan  8 12:55 gvn-revert.glade
lrwxrwxrwx   1 root root    14 Jan  9 23:20 gvn-revert.png -> gvn-revert.png
-rw-r--r--   1 root root 19249 Jan  8 12:55 gvn-update.glade
lrwxrwxrwx   1 root root    14 Jan  9 23:20 gvn-update.png -> gvn-update.png
-rw-r--r--   1 root root 13156 Jan  8 12:55 gvn-window.svg
-rw-r--r--   1 root root  6236 Jan  8 12:55 progressWindow.glade
-rw-r--r--   1 root root  6897 Jan  8 12:55 revisionChooser.glade
-rw-r--r--   1 root root 29524 Jan  8 12:55 statuswidget.glade

As you can see, the images are symlinked to themselves.

The versions used are 0.5-4.fc10 and 0.5-5.fc11
Comment 1 Xavier Lamien 2009-01-15 17:18:28 EST
Sorry for my late reply.
A new release is on its way and should be available soonish
Comment 2 Erik van Pienbroek 2009-01-18 12:39:48 EST
I just tried gnubversion 0.5-5.fc10 and both problems seems to be solved:

$ ls /usr/share/gnubversion/* -al
-rw-r--r-- 1 root root 37172 jan 12 00:06 /usr/share/gnubversion/about.glade
-rw-r--r-- 1 root root  4172 jan 12 00:06 /usr/share/gnubversion/commonOptions.glade
-rw-r--r-- 1 root root  6972 jan 12 00:06 /usr/share/gnubversion/fileSelector.glade
-rw-r--r-- 1 root root 32305 jan 12 00:06 /usr/share/gnubversion/gnubversion-logo.svg
-rw-r--r-- 1 root root 22300 jan 12 00:06 /usr/share/gnubversion/gvn-add.glade
lrwxrwxrwx 1 root root    47 jan 18 01:25 /usr/share/gnubversion/gvn-add.png -> /usr/share/icons/hicolor/24x24/apps/gvn-add.png
-rw-r--r-- 1 root root 35241 jan 12 00:06 /usr/share/gnubversion/gvn-checkout.glade
-rw-r--r-- 1 root root 21600 jan 12 00:06 /usr/share/gnubversion/gvn-commit.glade
lrwxrwxrwx 1 root root    50 jan 18 01:25 /usr/share/gnubversion/gvn-commit.png -> /usr/share/icons/hicolor/24x24/apps/gvn-commit.png
-rw-r--r-- 1 root root 20164 jan 12 00:06 /usr/share/gnubversion/gvn-remove.glade
lrwxrwxrwx 1 root root    50 jan 18 01:25 /usr/share/gnubversion/gvn-remove.png -> /usr/share/icons/hicolor/24x24/apps/gvn-remove.png
-rw-r--r-- 1 root root 20110 jan 12 00:06 /usr/share/gnubversion/gvn-revert.glade
lrwxrwxrwx 1 root root    50 jan 18 01:25 /usr/share/gnubversion/gvn-revert.png -> /usr/share/icons/hicolor/24x24/apps/gvn-revert.png
-rw-r--r-- 1 root root 19249 jan 12 00:06 /usr/share/gnubversion/gvn-update.glade
lrwxrwxrwx 1 root root    50 jan 18 01:25 /usr/share/gnubversion/gvn-update.png -> /usr/share/icons/hicolor/24x24/apps/gvn-update.png
-rw-r--r-- 1 root root 13156 jan 12 00:06 /usr/share/gnubversion/gvn-window.svg
-rw-r--r-- 1 root root  6236 jan 12 00:06 /usr/share/gnubversion/progressWindow.glade
-rw-r--r-- 1 root root  6897 jan 12 00:06 /usr/share/gnubversion/revisionChooser.glade
-rw-r--r-- 1 root root 29524 jan 12 00:06 /usr/share/gnubversion/statuswidget.glade

However, there isn't any build available yet for rawhide: http://koji.fedoraproject.org/koji/packageinfo?packageID=6542
Comment 3 Xavier Lamien 2009-03-02 04:11:19 EST
That should be fixed now.

Note You need to log in before you can comment on or make changes to this bug.