Bug 479584 - Login Greeter hangs after selecting a username
Login Greeter hangs after selecting a username
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-11 13:34 EST by Phil Godfrin
Modified: 2015-01-14 18:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 16:03:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Godfrin 2009-01-11 13:34:28 EST
Description of problem:
Login Greeter shows user names, and ...other. After selecting a username, and entering the password, the blue sun graphic screen returns with the progress meter. The login never completes - the system completely stops.

However, if I select "other", then type in the userid and password, the login completes into a gnome session.

Version-Release number of selected component (if applicable):


How reproducible:
This happens everytime.

Steps to Reproduce:
1.click on a user name
2.enter password
3.login hangs - progress meter stops under the "a" in Fedora
  
Actual results:
login never gets to desktop

Expected results:
desktop gui

Additional info:
This install of fc10 was upgraded from fc9 and that from fc8 - all of which had KDE configured. Naturally I wanted to continue using KDE, so I switched /etc/sysconfig/desktop to specify KDE - which produces a different greeter screen - which does not have the ability to select a different user (like the Gnome greeter does). Which means I was not able to logon at all - same thing - it would just hang.
Comment 1 Phil Godfrin 2009-01-17 08:47:36 EST
Is there anything I can add to help move this issue forward?
tx
Comment 2 Phil Godfrin 2009-02-03 13:51:06 EST
Anything?
pg
Comment 3 Ray Strode [halfline] 2009-02-09 09:56:56 EST
would you mind attaching /var/log/gdm/:0-slave.log?

Another useful thing would be if after a failed login if you could:

1) hit ctrl-alt-f2
2) login as the user
3) cp ~/.xsession-errors /tmp/xsession-errors

and then attach /tmp/xsession-errors

(the reason why we need the cp step is that ~/.xsession-errors gets overwritten each login)
Comment 4 Phil Godfrin 2009-02-11 12:39:23 EST
Thanks - I will do that this weekend. However, the machine appears to stop completely, so I don't know if I can hit ctrl-alt-f2. If I select the other... entry and manually type in the userid/pw then it goes through. So I'm not sure how to capture the xsession-errors file in the event of a failure.

But I'll give it whirl...
pg
Comment 5 Phil Godfrin 2009-02-16 12:10:00 EST
The story's over folks. Last week I killed my old Intel P4 mobo (AGP Radeon 9800Pro) which is the system where I installed Fedora. Which means I ended up with a new system (Gigabyte P45, DDR3, GTX 260) and upgrading the aforementioned Fedora 10 with the new hardware. After a small struggle with the new ethernet card(s) and a new nVidia driver the system came up normally. Including using the Greeter menu in both Gnome and KDE.

Sorry we couldn't get to the bottom of this, but I wonder if my hardware was just too old... I suppose we can close this bug...

If there are some log files or other information that may have survived the upgrade and someone wants me to send them along, I am willing.

regards,
pg
Comment 6 erik slagter 2009-04-07 06:19:29 EDT
This was to be expected. I have the same issue, it's xorg's x11 "intel" driver related, which you are not using anymore.
Comment 7 erik slagter 2009-04-07 06:21:18 EDT
see also https://bugzilla.redhat.com/show_bug.cgi?id=485630

Note You need to log in before you can comment on or make changes to this bug.