Bug 479623 - Disable "Check for Updates" in Firefox
Disable "Check for Updates" in Firefox
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
: Reopened
Depends On: 189019
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 03:24 EST by lihuang
Modified: 2009-01-14 04:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 189019
Environment:
Last Closed: 2009-01-14 04:31:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lihuang 2009-01-12 03:24:46 EST
+++ This bug was initially created as a clone of Bug #189019 +++

Description of problem:
Firefoz on FC5 does not do binary updates from Mozilla site.

Version-Release number of selected component (if applicable):
1.5.0

How reproducible:
Go to Help -> Check for Updates

Steps to Reproduce:
1. Open Firefox as 'root' user
2. Click on Help Menu
3. Select "Check for Updates"
  
Actual results:
Firefox displays "There are no updates available to Firefox" when the updates
are available. 

Expected results:
Update firefox when updates are available. Else disable this feature.

Additional info:
since firefox is compiled with fedora specific compile options, binary
compatibility with Mozilla firefox updates is not possible. Either use mozilla
compilation environment to keep binary updates or remove this option entirely. 

Users will not be led to believe no updates are available when updates are
available.

See discussion thread here
https://www.redhat.com/archives/fedora-test-list/2006-April/msg00353.html

--- Additional comment from petrosyan@gmail.com on 2006-10-06 11:34:47 EDT ---

"Check for Updates" has been disabled in firefox-1.5.0.7-1.fc5
Please close this bug.

--- Additional comment from lihuang@redhat.com on 2009-01-11 10:31:49 EDT ---

Created an attachment (id=328661)
"Check for Updates " is not disabled.

on firefox-3.0.5-1.fc10.i386. "Check for Updates " is not disabled.
Comment 1 Matěj Cepl 2009-01-12 06:22:14 EST
??? FC5 is not supported for at least summer 2007???
Comment 2 lihuang 2009-01-13 05:53:08 EST
lihuang -> mcepl:

*Check for Updates * is enabled on ff3. and can not find any updates even the latest release does exist.

According to comment#1 of bug#189019.  I think *Check for Updates * should have been disabled on ff3 as well.
so I cloned this bug.
I am sorry if I did not clarify clearly.

can I reopen the issue ?
Comment 3 Matěj Cepl 2009-01-13 18:52:33 EST
Are you sure you are not actually running mozilla.com binary? What's the build ID in Help/About ... Does it containt a word "Fedora"? E.g., something like

Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.9.0.5) Gecko/2008121622 Fedora/3.0.5-1.fc10 Firefox/3.0.5 Ubiquity/0.1.4

Thanks a lot when you reply to this question.
Comment 4 Matěj Cepl 2009-01-13 18:54:05 EST
Just to be sure about versions -- cannot reproduce the issue either with firefox-3.0.5-1.fc10.i386 nor with firefox-3.1-0.4.beta2.fc11.x86_64.
Comment 5 lihuang 2009-01-13 20:46:45 EST
Version-Release number of selected component:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121622 Fedora/3.0.5-1.fc10 Firefox/3.0.5

Steps to Reproduce:
1. Open Firefox as 'root' user
2. Click on Help Menu
3. Select "Check for Updates"
Comment 6 Matěj Cepl 2009-01-14 04:31:26 EST
(In reply to comment #5)
> Steps to Reproduce:
> 1. Open Firefox as 'root' user

Stop right here -- running X as root user is not supported and any bugs which cannot be reproduced with normal user are NOTABUG. Like this one.

Note You need to log in before you can comment on or make changes to this bug.