This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 479624 - [hi_IN] Glyphs overlap in artificially emboldened fonts
[hi_IN] Glyphs overlap in artificially emboldened fonts
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 03:26 EST by A S Alam
Modified: 2013-07-02 20:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 18:10:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot for Bug with Red Line (10.89 KB, image/png)
2009-01-12 03:26 EST, A S Alam
no flags Details
The text I'm playing with (7.80 KB, application/vnd.oasis.opendocument.text)
2009-01-12 06:16 EST, David Tardon
no flags Details
easiest example (9.49 KB, application/vnd.oasis.opendocument.text)
2009-01-12 08:28 EST, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 98024 None None None Never

  None (edit)
Description A S Alam 2009-01-12 03:26:54 EST
Created attachment 328710 [details]
Screenshot for Bug with Red Line

Description of problem:
while making character bold, Text intermix few words. Gedit is working fine.
Copy/Paste also have problem.

Version-Release number of selected component (if applicable):
openoffice.org-core-3.0.0-9.10.fc10.i386

How reproducible:
100%

Steps to Reproduce:
1. Open oowriter
2. Copy Text from http://www.bbc.co.uk/hindi/business/story/2009/01/090111_satyam_meeting_ac.shtml
3. Paste in oowriter
  
Actual results:
Character inter-mix as shown in screenshot.

Expected results:
Should be distant enough.

Additional info:
Comment 1 Caolan McNamara 2009-01-12 05:16:28 EST
Could you attach a sample .odt of the problem, I want to be sure I'm looking at the same problem using the same font and fontsize.
Comment 2 David Tardon 2009-01-12 06:12:36 EST
It looks like width of the के character is handled wrongly in some cases. When I make it bold, it's OK, but when I make bold at least one character on the right side of it, they overlap to some extent. Visual appearance of the character is not changed, but oowriter now seems to think it's narrower.

The font is DejaVu Sans 12.
Comment 3 David Tardon 2009-01-12 06:16:31 EST
Created attachment 328720 [details]
The text I'm playing with
Comment 4 Caolan McNamara 2009-01-12 08:28:36 EST
Created attachment 328730 [details]
easiest example

Looks like the font that gets used is Lohit Hindi, and it doesn't have a bold variant. So the artificial emboldening presumably is the cause of the problem
Comment 5 Caolan McNamara 2009-01-13 04:14:25 EST
I'll take this one
Comment 6 Caolan McNamara 2009-01-13 05:19:50 EST
Fix checked in, will be in >= 3.0.1-15.2 unless upstream sees a massive flaw in the workaround
Comment 7 Fedora Update System 2009-01-29 18:10:00 EST
openoffice.org-3.0.1-15.2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.