Bug 479680 - Missing Dependency: sqlite-devel is needed by package rpm-devel
Missing Dependency: sqlite-devel is needed by package rpm-devel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm (Show other bugs)
4.8
All Linux
medium Severity medium
: beta
: ---
Assigned To: Jindrich Novy
BaseOS QE Security Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 08:58 EST by Nick Petrov
Modified: 2013-07-02 19:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:04:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Petrov 2009-01-12 08:58:20 EST
Missing Dependency: sqlite-devel is needed by package rpm-devel

proposed fixes:
a) remove sqlite-devel dependency from rpm-devel package
b) include sqlite-devel package in RHEL 4.8
Comment 1 Panu Matilainen 2009-01-12 10:44:26 EST
Hmm, yup.. 4.3.3-29_nonptl grew a couple of new dependencies too many:
+Requires: nss-devel
+Requires: sqlite-devel

RHEL 4 version of rpm doesn't have sqlite backend at all so the right thing to do is remove sqlite-devel dependency. Also the RHEL 4 version doesn't use NSS but beecrypt, so rpm-devel should Requires beecrypt-devel, not nss-devel.
Comment 10 errata-xmlrpc 2009-05-18 16:04:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0951.html

Note You need to log in before you can comment on or make changes to this bug.