Bug 479694 - for any printers added with lpadmin, the job options are not visible in the system-config-printer
for any printers added with lpadmin, the job options are not visible in the s...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-printer (Show other bugs)
5.2
i686 Linux
low Severity medium
: rc
: ---
Assigned To: Tim Waugh
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 10:00 EST by Thierry Leurent
Modified: 2013-03-11 11:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-11 11:03:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thierry Leurent 2009-01-12 10:00:44 EST
Description of problem:
On an RHEL 5.2 (uptodate) when you create a new printer with the lpadmin command using -o (-0 cpi-defalut=12) and you launch the system-config-printer program, tou can see the printer. But when you go to the job options, you don't see the configured option (cpi = 12 for example). If you want add this default option, you don't see cpi in the list of default options.

When you look at the /etc/cups/printers.conf, you see "Option cpi 12".
If you want use the system-config-printer to add one other default option to your printer, the program crash and in printers.conf, you see only the "new" option.

Version-Release number of selected component (if applicable):
RHEL 5.2 System-config-printer 0.7.32.8

How reproducible:
Easily, create a printer with lpadmin

Steps to Reproduce:
1.  lpadmin -p 1D752_A4_LANDSCAPE -D "HP3505x 1D752 it Landscape 132C * 40L" -L "Salle CTI" -E -v socket://10.10.17.104:9100 -m HP_Color_LaserJet_CP3505.ppd -o PageSize-default=A4 -o Resolution-default=150 -o page-top-default=18 -o page-right-default=9 -o page-bottom-default=54 -o page-left-default=18 -o cpi-default=12 -o landscape-default=true -o lpi-default=6 -o scaling-default=100 -o wrap-default=true
2. cat /etc/cups/printers.conf
3. open system-config-printer, go on the printer and go to job options.
4. Add a new default job option.
5. cat /etc/cups/printers.conf

  
Actual results:
You don't see the default job options passed by the lpadmin command, system-config-printer crash after adding a new default options and system-config-printer

Expected results:
Be able to see job options from a printer installed with lpadmin, be able to add a job default option on a printer installed with lpadmin, keep initial options when you add a new default job option.

Additional info:
Comment 1 Thierry Leurent 2009-01-12 10:38:57 EST
The PageSize parameter is not a Job Default Option. When the printer's parameters are loaded you can see this message "File "/usr/share/system-config-printer/system-config-printer.py", line 1228, in fillPrinterTab
    supported = printer.possible_attributes[attr][1]
KeyError: 'PageSize'" if you launch system-config-printer from a terminal.

Sorry but I'm not a professional printer installer....
Comment 2 Tim Waugh 2009-01-12 12:07:52 EST
Setting options of the form '*-default' sets job default options.  To set PPD options, just use '-o PageSize=A4 -o Resolution=150' etc.

system-config-printer should be made to deal with job options it doesn't know without causing a traceback.

The other problems you are seeing may be a result of bug #227678.
Comment 3 RHEL Product and Program Management 2009-03-26 12:47:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 5 RHEL Product and Program Management 2009-11-06 13:42:22 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 7 RHEL Product and Program Management 2010-08-09 14:12:04 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 Jiri Popelka 2013-03-11 11:03:33 EDT
RHEL-5.10 (the next RHEL-5 minor release) is going to be the first production phase 2 [1] release of RHEL-5.
Since phase 2 we'll be addressing only security and critical issues.
I'm closing this ticket as WONTFIX because this problem is neither security nor critical.

[1] https://access.redhat.com/support/policy/updates/errata/

Note You need to log in before you can comment on or make changes to this bug.