Bug 479762 - ecryptfsecryptfs-setup-private broken..
ecryptfsecryptfs-setup-private broken..
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ecryptfs-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael Halcrow
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 17:00 EST by Sachin Garg
Modified: 2009-02-16 05:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 05:48:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix nss passphrase (un)wrapping problems (7.66 KB, patch)
2009-01-30 08:20 EST, Michal Hlavinka
no flags Details | Diff
make most of the code compatible with -Werror (50.20 KB, patch)
2009-01-30 08:22 EST, Michal Hlavinka
no flags Details | Diff

  None (edit)
Description Sachin Garg 2009-01-12 17:00:04 EST
Description of problem:

While executing the ecryptfs-setup-private I receive following error.


ecryptfs-insert-wrapped-passphrase-into-keyring  ecryptfs-setup-private                           ecryptfs-wrap-passphrase
[sachin@fedora-rawhide ~]$ ecryptfs-setup-private 
Enter your login passphrase: 
Enter your mount passphrase [leave blank to generate one]: 

************************************************************************
YOU SHOULD RECORD THIS MOUNT PASSPHRASE AND STORE IN A SAFE LOCATION:
5f815da4d2fe55f618f3b708703f6c2f
THIS WILL BE REQUIRED IF YOU NEED TO RECOVER YOUR DATA AT A LATER TIME.
************************************************************************



Warning: Using default salt value (undefined in ~/.ecryptfsrc)
Error: Wrapping passphrase failed [-5]
Info: Check the system log for more information from libecryptfs
ERROR: Could not wrap passphrase

from /var/log/messages
----------------------

Jan 12 15:54:05 localhost ecryptfs-wrap-passphrase: Error attempting to parse .ecryptfsrc file; rc = [-5]
Jan 12 15:54:06 localhost ecryptfs-wrap-passphrase: ecryptfs_wrap_passphrase: PK11_CipherOp() error; SECFailure = [-1]; PORT_GetError() = [-8191]

Version-Release number of selected component (if applicable):

ecryptfs-utils-68-0.fc11.i386

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michal Hlavinka 2009-01-30 08:20:48 EST
Created attachment 330461 [details]
fix nss passphrase (un)wrapping problems

you'll need to apply werror1 patch if you want to apply this cleanly with fuzz=0
Comment 2 Michal Hlavinka 2009-01-30 08:22:17 EST
Created attachment 330462 [details]
make most of the code compatible with -Werror

this also fixes some minor problems or potential bugs
Comment 3 Michal Hlavinka 2009-02-16 05:37:50 EST
fixed since ecryptfs-utils-70-1

Note You need to log in before you can comment on or make changes to this bug.