Bug 479809 - CUPS web interface admin URLs are incorrect
CUPS web interface admin URLs are incorrect
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Tim Waugh
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 04:42 EST by Tim Waugh
Modified: 2009-09-02 07:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:25:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CUPS Bugs and Features 3022 None None None Never

  None (edit)
Description Tim Waugh 2009-01-13 04:42:51 EST
Description of problem:
When a CUPS server's domain name maps to 127.0.0.1 locally for the server, the URLs it provides in the web interface look like "https://127.0.0.1:631/admin/...".  The domain name should be used in the URLs instead.

Version-Release number of selected component (if applicable):
1.3.7-8.el5

How reproducible:
100%

Steps to Reproduce:
1.Edit /etc/hosts so that the local domain name is resolved as 127.0.0.1.
2.Reboot
3.Now go to http://cups-server:631/ and try to perform administration tasks.
  
Actual results:
Hyperlinks point to local (client) machine instead of server.

Expected results:
Hyperlinks point to CUPS server.

Additional info:
Easy fix.
Comment 5 errata-xmlrpc 2009-09-02 07:25:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1360.html

Note You need to log in before you can comment on or make changes to this bug.