Bug 479810 - Segmentation fault occurred in crash bt command on RHEL5.3 Snapshot5 dom0.
Segmentation fault occurred in crash bt command on RHEL5.3 Snapshot5 dom0.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: crash (Show other bugs)
5.3
All Linux
urgent Severity high
: rc
: ---
Assigned To: Dave Anderson
Martin Jenner
: Regression, ZStream
Depends On: 478904
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 04:49 EST by RHEL Product and Program Management
Modified: 2010-10-23 02:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
* The bt command displays a task's kernel-stack backtrace. When running this command against an x86 Xen kernel vmcore, crash did not correctly handle the transition from the IRQ stack back to the process stack, leading to a segmentation fault. The version of crash provided with this advisory contains a patch that corrects this issue, allowing users to analyse a vmcore file from a system with an x86 Xen kernel.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 18:53:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RHEL Product and Program Management 2009-01-13 04:49:50 EST
This bug has been copied from bug #478904 and has been proposed
to be backported to 5.3 z-stream (EUS).
Comment 3 RHEL Product and Program Management 2009-01-13 05:13:43 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 4 Dave Anderson 2009-01-13 10:23:55 EST
RHEL5 Z-stream has been requested: 

  https://engineering.redhat.com/rt3/Ticket/Display.html?id=33748
Comment 5 Dave Anderson 2009-01-13 12:55:33 EST
MODIFIED: CVS Tag: crash-4_0-7_2_3_el5_3_1
Comment 8 Ruediger Landmann 2009-01-14 22:46:34 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
* The bt command displays a task's kernel-stack backtrace. When running this command against an x86 Xen kernel vmcore, crash did not correctly handle the transition from the IRQ stack back to the process stack, leading to a segmentation fault. The version of crash provided with this advisory contains a patch that corrects this issue, allowing users to analyse a vmcore file from a system with an x86 Xen kernel.
Comment 10 errata-xmlrpc 2009-01-20 18:53:45 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0049.html

Note You need to log in before you can comment on or make changes to this bug.