Bug 479857 - SELinux prevents save of kvm machine
SELinux prevents save of kvm machine
Status: CLOSED DUPLICATE of bug 498750
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 11:55 EST by Guy Andrews
Modified: 2009-05-12 16:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 16:31:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guy Andrews 2009-01-13 11:55:49 EST
Description of problem: SELinux is preventing qemu-kvm (qemu_t) "read" to sh (bin_t)
"restorecon -v 'sh'" does not prevent the error


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Build XP and update as a virtual machine.
2. Run virtual machine using "Virtual Machine Manager"
3. Use save option to save in /var/lib/libvirt or /var/lib/libvirt/images
  
Actual results: SELinux prevents read access to the shell script


Expected results: Virtual Machine saved


Additional info: The virtual machine hangs and the save does not complete
Comment 1 Daniel Berrange 2009-05-12 16:31:23 EDT
I realize this bug was reported against Fedora 10, however, it is not practical to fix this problem with SELinux + save/restore in libvirt at this time. We have a planned change of the way we deal with save/restore in libvirt which will address it properly. Thus I'm closing this as a dup of the bug tracking that future enhancement.

*** This bug has been marked as a duplicate of bug 498750 ***

Note You need to log in before you can comment on or make changes to this bug.