Bug 479883 - setroubleshoot-server RPM lacks dependency on rpm-python
setroubleshoot-server RPM lacks dependency on rpm-python
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: setroubleshoot (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Daniel Walsh
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 15:02 EST by Vadym Chepkov
Modified: 2013-04-24 15:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-24 15:48:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadym Chepkov 2009-01-13 15:02:26 EST
setroubleshoot-server-2.0.5-3.el5 misses dependency on rpm-python. During kickstart installation rpm-python is not getting installed when setrobleshoot-server is selected which causes it to fail:

Traceback (most recent call last):
  File "/usr/sbin/setroubleshootd", line 111, in ?
    from setroubleshoot.server import RunFaultServer
  File "/usr/lib/python2.4/site-packages/setroubleshoot/server.py", line 45, in ?
    from setroubleshoot.analyze import *
  File "/usr/lib/python2.4/site-packages/setroubleshoot/analyze.py", line 43, in ?
    from setroubleshoot.avc_audit import *
  File "/usr/lib/python2.4/site-packages/setroubleshoot/avc_audit.py", line 42, in ?
    from setroubleshoot.util import *
  File "/usr/lib/python2.4/site-packages/setroubleshoot/util.py", line 70, in ?
    import rpm
ImportError: No module named rpm
Comment 1 Milos Malik 2013-03-14 03:33:44 EDT
# rpm -e rpm-python
error: Failed dependencies:
	rpm-python is needed by (installed) python-rhsm-1.0.10-1.el5.i386
	rpm-python is needed by (installed) yum-3.2.22-40.el5.noarch
	rpm-python is needed by (installed) system-config-users-1.2.51-7.el5.noarch
	rpm-python is needed by (installed) rhn-client-tools-0.4.20-86.el5.noarch
	rpm-python is needed by (installed) system-config-network-tui-1.3.99.21-1.el5.noarch
#

setroubleshoot-server should require rpm-python package, because it does not work when the package is not installed:

# setroubleshootd -f -v
Traceback (most recent call last):
  File "/usr/sbin/setroubleshootd", line 111, in ?
    from setroubleshoot.server import RunFaultServer
  File "/usr/lib/python2.4/site-packages/setroubleshoot/server.py", line 45, in ?
    from setroubleshoot.analyze import *
  File "/usr/lib/python2.4/site-packages/setroubleshoot/analyze.py", line 43, in ?
    from setroubleshoot.avc_audit import *
  File "/usr/lib/python2.4/site-packages/setroubleshoot/avc_audit.py", line 42, in ?
    from setroubleshoot.util import *
  File "/usr/lib/python2.4/site-packages/setroubleshoot/util.py", line 72, in ?
    import rpm
ImportError: No module named rpm
#

Note You need to log in before you can comment on or make changes to this bug.