Bug 479892 - Cannot stat /lib/kbd/consoletrans/iso01 when Installing 2.6.28 kernel on x86_64
Cannot stat /lib/kbd/consoletrans/iso01 when Installing 2.6.28 kernel on x86_64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 16:28 EST by Joachim Frieben
Modified: 2009-02-21 04:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-21 04:53:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Excerpt from rpm output produced by installing 2.6.27.12-170.2.5.fc10.x86_64 (1.92 KB, text/plain)
2009-01-21 13:01 EST, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2009-01-13 16:28:19 EST
Description of problem:
Installing the latest F10 kernel update candidate 2.6.28-3.fc10 leads to the following error message

  $ rpm -ihv --force kernel-2.6.28-3.fc10.x86_64.rpm 
  Preparing...                ##################################### [100%]
     1:kernel                 ##################################### [100%]
  cp: cannot stat `/lib/kbd/consoletrans/iso01': No such file or directory

Version-Release number of selected component (if applicable):
kernel-2.6.28-3.fc10.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. rpm -ihv --force kernel-2.6.28-3.fc10.x86_64.rpm
  
Actual results:
/lib/kbd/consoletrans/iso01 is accessed but does not exist.

Expected results:
Installation of the new kernel packages completes without complaint.

Additional info:
- this issue has appeared with kernel-2.6.28-1.fc10.x86_64.rpm
- kernel-2.6.28-1.fc10.i686 installs flawlessly on some x86 system
- kbd-1.12-31.fc9.x86_64 is the package owning /lib/kbd/consoletrans/*
Comment 1 Chuck Ebbert 2009-01-21 11:03:28 EST
Can you get some more information by using rpm -i -vv --force ?
Comment 2 Joachim Frieben 2009-01-21 13:01:15 EST
Created attachment 329625 [details]
Excerpt from rpm output produced by installing 2.6.27.12-170.2.5.fc10.x86_64

For various reasons, I have reverted to kernel 2.6.27.12-170.2.5.fc10.x86_64 which now turns out to trigger the same message [as does 2.6.27.10-169.fc10.x86_64 now as well]. It seems like installing kernel 2.6.28-1.fc10.x86_64 has somehow made a persistent change to the system.
Comment 3 Joachim Frieben 2009-02-21 04:53:50 EST
This appears to have been a transient issue. After reinstalling F10 w/updates as of 2009-02-21, installing kernel-2.6.29-0.33.rc5.fc10.x86_64 does not trigger this error message anymore. kernel-2.6.28.x packages have not even made their way into repo "updates-testing". Thus closing as "RAWHIDE".

Note You need to log in before you can comment on or make changes to this bug.