Bug 480025 - NVIDIA Quadro FX570/FX1700 lose sync on RHEL5U2 and RHEL5U3 Snap5.
NVIDIA Quadro FX570/FX1700 lose sync on RHEL5U2 and RHEL5U3 Snap5.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-nv (Show other bugs)
5.3
All Linux
high Severity high
: rc
: 5.4
Assigned To: Adam Jackson
desktop-bugs@redhat.com
:
Depends On:
Blocks: 441909 483784
  Show dependency treegraph
 
Reported: 2009-01-14 11:21 EST by Alan Matsuoka
Modified: 2011-01-24 18:39 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NVIDIA Quadro FX 570 and Quadro FX 1700 graphics cards obtain modetimings from the X server for mode validation ("native modesetting"). Previously, xorg-x11-drv-nv did not support native modesetting, and therefore would not work with these cards. With native modesetting supported in xorg-x11-drv-nv, this driver now works with Quadro FX 570 and Quadro FX 1700 graphics cards.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:11:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci.txt (49.91 KB, text/plain)
2009-01-14 11:21 EST, Alan Matsuoka
no flags Details
syslog (30.19 KB, text/plain)
2009-01-14 11:22 EST, Alan Matsuoka
no flags Details
X.log (60.69 KB, text/plain)
2009-01-14 11:23 EST, Alan Matsuoka
no flags Details
XConfig.test (737 bytes, text/plain)
2009-01-14 11:23 EST, Alan Matsuoka
no flags Details

  None (edit)
Description Alan Matsuoka 2009-01-14 11:21:21 EST
Created attachment 329017 [details]
lspci.txt

ERIC LI <ericli@tw.ibm.com> -
---Problem Description---
NVIDIA Quadro FX570/FX1700 lose sync when installing RHEL5U2 and RHEL5U3 Snap5.

Contact Information = ericli@tw.ibm.com

---Additional Hardware Info---
43V5766 - NVIDIA Quadro FX 1700
43V5783 - NVIDIA Quadro FX 570


---uname output---
Linux localhost.localdomain 2.6.18-125.el5 #1 SMP Mon Dec 1 17:38:25 EST 2008 x86_64 x86_64 x86_64
GNU/Linux

Machine Type = x3500 M2, 7839

---Debugger---
Comments from a previous conversation with NVIDIA:
- the version of the nv driver which RH backported to RHEL 5.2
completely relies on the mode validation of the core X.org X
server in order to get correct modetimings (this is so-called
"native modesetting"), as opposed to the modesetting code in the
pre-g80 nv driver, which always uses the modetimings which the
VBIOS selected at POST time

- when we implemented support for this in the nv driver, the X.org
server version which the nv driver was implemented against had
correct mode validation support, such that native modesetting
works properly

- for the nv driver to work on this GPU, RH would need to backport
the appropriate mode validation fixes in the core X.org X server;
RH's X server engineers are much more familiar with the X server's
mode validation code than we are, so they will know better than
NVIDIA what changes are needed
We believe this problem would be present in any open source X driver
that uses "native modesetting". We do not know, off hand, if any other
X driver backported to RHEL 5.2 takes advantage of native modesetting.
Certainly, most of the actively developed X drivers in top of tree X.org
use native modesetting.

---Steps to Reproduce---
1. Plug NVIDIA Quadro FX 570 in slot2 then connect to the monitor.
2. Install RHEL5U2/RHEL5U3 Snap5 64bit via DVD-ROM.
3. Monitor has a problem when install in graphic mode.
The messages shows at terminal 1 (Ctrl+Alt+F1):
-----------------------------------------------
running /sbin/loader
Running anaconda, the Red Hat Enterprise Linux Server System installer - please wait...
Probing for video card: nVidia Corporation Quadro FX 570

PREFETCH window: disabled.
1..2..3..4..5..X server started successfully.
Starting graphical installation...
------------------------------------------------

---XFree86/X.org Component Data---
Adapter and monitor type: IBM E74

=Comment: #5=================================================
Edjunior Barbosa Machado <emachado@linux.vnet.ibm.com> -
Hi Eric,

have you tried to use "xdriver=vesa" on kernel command line in order to help you starting the
graphical mode interface?

Are you able to please provide the "lspci -vv" output and X server log (I think it can be found on
/tmp/X.log during installation)?

Thank you.

=Comment: #8=================================================
ERIC LI <ericli@tw.ibm.com> -
Hi Edjunior

It is workable to start the graphical mode interface by using "xdriver=vesa" on kernel command line.

I uploaded two files: lspci.txt and X.log.

Thanks.

=================================================
Hello Red Hat,

I have noticed that there are some other bugs
against NVIDIA video drivers, such as:

https://bugzilla.redhat.com/show_bug.cgi?id=428438
https://bugzilla.redhat.com/show_bug.cgi?id=249416

Although they are issues against different chipset models, they seems to be
addressing a similar problem during installation.

Please let us to know in case you need any additional information.
Comment 1 Alan Matsuoka 2009-01-14 11:22:29 EST
Created attachment 329018 [details]
syslog
Comment 2 Alan Matsuoka 2009-01-14 11:23:00 EST
Created attachment 329019 [details]
X.log
Comment 3 Alan Matsuoka 2009-01-14 11:23:34 EST
Created attachment 329020 [details]
XConfig.test
Comment 4 Issue Tracker 2009-01-19 14:52:38 EST
Hello,
This is a note on this issue sent by NVIDIA Engineering:

On RH5U2 64b we see a monitor out of range issue with fx570 and fx1700
during x install.

Thanks to Andy R for the following summary:

- the version of the nv driver which RH backported to RHEL 5.2 
completely relies on the mode validation of the core X.org X 
server in order to get correct modetimings (this is so-called 
"native modesetting"), as opposed to the modesetting code in the 
pre-g80 nv driver, which always uses the modetimings which the 
VBIOS selected at POST time 

- when we implemented support for this in the nv driver, the X.org 
server version which the nv driver was implemented against had 
correct mode validation support, such that native modesetting 
works properly 

- for the nv driver to work on this GPU, RH would need to backport 
the appropriate mode validation fixes in the core X.org X server; 
RH's X server engineers are much more familiar with the X server's 
mode validation code than we are, so they will know better than 
NVIDIA what changes are needed 

We believe this problem would be present in any open source X driver 
that uses "native modesetting". We do not know, off hand, if any other 
X driver backported to RHEL 5.2 takes advantage of native modesetting. 
Certainly, most of the actively developed X drivers in top of tree X.org 
use native modesetting. 


This event sent from IssueTracker by jkachuck 
 issue 255851
Comment 5 Russell Doty 2009-01-19 15:09:27 EST
Did this work on RHEL 5.2? If so, it should be classified as a regression.
Comment 6 Issue Tracker 2009-01-19 15:13:24 EST
Sending old note up to engineering:
------- Comment From ericli@tw.ibm.com 2009-01-17 01:21 EDT-------
Hi
I uploaded sosreport result file,
sosreport-localhost-484249-b95119.tar.bz2.

I do not think this is a regression issue.
This issue also happens on RHEL5.2 and RHEL5.3 RC2.
Many thanks. 




This event sent from IssueTracker by jkachuck 
 issue 255851
Comment 7 Matěj Cepl 2009-01-21 10:35:33 EST
This is actually using VESA driver, not NV.
Comment 8 Russell Doty 2009-01-21 10:55:56 EST
Per initial comment 8 (comment 8 in comment 1...), it appears that VESA works but that NV doesn't. Can someone confirm?
Comment 9 Russell Doty 2009-02-02 16:38:00 EST
This is occuring with the NV driver, not the VESA driver.
Comment 10 Matěj Cepl 2009-02-03 09:57:50 EST
(In reply to comment #9)
> This is occuring with the NV driver, not the VESA driver.

Attachment 329019 [details] in the comment 2 is from VESA driver.
Comment 11 Joseph Kachuck 2009-02-05 12:00:25 EST
Hello,
My understanding is this is may be due to using the VESA module, and not the NV module. The issue is the NV module is also missing appropriate mode validation fixes in the core X.org X server. So the request is to correct the NV module so the VESA module would not be needed.

IBM or NVIDIA please comment if this is an incorrect explanation of the current issue.

Thank You
Joe Kachuck
Comment 12 Adam Jackson 2009-02-10 17:11:17 EST
The G80+ code in the nv driver in RHEL5 does use the new modesetting code from upstream.  We're quite likely to update that for 5.4, so.

Moving to nv component.
Comment 13 RHEL Product and Program Management 2009-03-11 12:18:58 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 18 Adam Jackson 2009-04-22 15:23:27 EDT
Reporter: Can we get an X log from attempting to run X with the nv driver on this hardware?  The driver does claim to support this PCI ID, so I'm curious whether it's just a mode validation failure or something more subtle.
Comment 19 Issue Tracker 2009-05-05 10:24:25 EDT
------- Comment From ericli@tw.ibm.com 2009-05-05 01:31 EDT-------
Hello
It can not get an X log from attempting to run X with the nv driver during
installing RHEL5.3.
The screen went black after loading vmlinuz and initrd.img.

Thanks.


This event sent from IssueTracker by jkachuck 
 issue 255851
Comment 20 Adam Jackson 2009-05-20 17:12:31 EDT
It is not necessary to get an X log from install time.  Installing in text mode and running X from the installed system will provide an equivalent X log.
Comment 23 Adam Jackson 2009-06-15 17:19:27 EDT
Interesting.  X log looks quite sane.  Does X actually come up and display in that run, or does it fail in the same way as in the installer?
Comment 27 Chris Ward 2009-07-03 14:20:39 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 33 Ruediger Landmann 2009-08-19 01:14:28 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
NVIDIA Quadro FX 570 and Quadro FX 1700 graphics cards obtain modetimings from the X server for mode validation ("native modesetting"). Previously, xorg-x11-drv-nv did not support native modesetting, and therefore would not work with these cards. With native modesetting supported in xorg-x11-drv-nv, this driver now works with Quadro FX 570 and Quadro FX 1700 graphics cards.
Comment 34 errata-xmlrpc 2009-09-02 07:11:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1342.html

Note You need to log in before you can comment on or make changes to this bug.