Bug 480119 - Yumex hangs with debuglevel = 5
Yumex hangs with debuglevel = 5
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-15 03:22 EST by Oleksandr
Modified: 2009-08-06 07:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-06 07:46:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oleksandr 2009-01-15 03:22:37 EST
Description of problem:
yumex hangs if yum debug level changed in /etc/yum.conf


Version-Release number of selected component (if applicable):
2.0.5 FC10

How reproducible:
Add "debuglevel = 5" line to /etc/yum.conf
Update any package

Steps to Reproduce:
1.set "debuglevel = 5" line in /etc/yum.conf
2.run yumex
3.update any package

Actual results:

Yumex hangs with this traceback:

Traceback (most recent call last):
  File "/usr/share/yumex/yumex.py", line 168, in on_queueProcess_clicked
    rc = self.processPackageQueue(self.queue.packages)
  File "/usr/share/yumex/yumex.py", line 604, in processPackageQueue
    rc, msg = self.yumbase._prepareTransaction(pkgs,doAll)        
  File "/usr/share/yumex/yumapi.py", line 211, in _prepareTransaction
    tx = self.update( po.pkg )
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 2816, in update
    ipkg.pkgtup)
  File "/usr/lib/python2.5/logging/__init__.py", line 1056, in log
    apply(self._log, (level, msg, args), kwargs)
  File "/usr/lib/python2.5/logging/__init__.py", line 1101, in _log
    self.handle(record)
  File "/usr/lib/python2.5/logging/__init__.py", line 1111, in handle
    self.callHandlers(record)
  File "/usr/lib/python2.5/logging/__init__.py", line 1148, in callHandlers
    hdlr.handle(record)
  File "/usr/lib/python2.5/logging/__init__.py", line 655, in handle
    self.emit(record)
  File "/usr/lib/python2.5/site-packages/yumgui/__init__.py", line 48, in emit
    msg = self.format(record)
  File "/usr/lib/python2.5/logging/__init__.py", line 630, in format
    return fmt.format(record)
  File "/usr/lib/python2.5/logging/__init__.py", line 418, in format
    record.message = record.getMessage()
  File "/usr/lib/python2.5/logging/__init__.py", line 288, in getMessage
    msg = msg % self.args
TypeError: not enough arguments for format string


Expected results:

Update without eroors


Additional info:

FC9 also has this bug
Comment 1 Bug Zapper 2009-06-09 06:43:50 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Tim Lauridsen 2009-08-06 07:46:29 EDT
I can reproduce the issue in F11.

I am not sure i will fix it in yumex 2.0.x, because it is in deep freeze and all development is done in Yumex NextGen (2.9.x) there is a total rewrite of yumex.

The issue don't exist in Yumex NextGen.

You can test the latest testbuild for F11 Here:

http://timlau.fedorapeople.org/files/yumex/

Note You need to log in before you can comment on or make changes to this bug.