Bug 480145 - clvmd should not be linked to readline & ncurses libs
clvmd should not be linked to readline & ncurses libs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Milan Broz
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-15 06:56 EST by Milan Broz
Modified: 2013-02-28 23:07 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 480144
Environment:
Last Closed: 2009-09-02 07:57:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Broz 2009-01-15 06:56:15 EST
+++ This bug was initially created as a clone of Bug #480144 +++
RHEL5 clone

Description of problem:

VERIFY	 	lvm2-cluster	 	DT_NEEDED requirements on libreadline.so.4 appearing in usr/lib/liblvm2clusterlock.so.2.02 on i386
VERIFY	 	lvm2-cluster	 	DT_NEEDED requirements on libncurses.so.5 appearing in usr/sbin/clvmd on i386

Previous build have no this dependency and clvmd do not need this, it is regression.

Caused by default option change "Enable readline by default if available." for liblvm2cmd.

lvm2-cluster need to use --disable-readline switch now.


# ldd /usr/sbin/clvmd
        libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003594600000)
        libdevmapper-event.so.1.02 => /lib64/libdevmapper-event.so.1.02 (0x0000003594e00000)
        libdevmapper.so.1.02 => /lib64/libdevmapper.so.1.02 (0x0000003594a00000)
        libdlm.so.2 => /usr/lib64/libdlm.so.2 (0x0000003595e00000)
        libcman.so.2 => /usr/lib64/libcman.so.2 (0x0000003596e00000)
        libreadline.so.5 => /usr/lib64/libreadline.so.5 (0x0000003596200000)
        librt.so.1 => /lib64/librt.so.1 (0x0000003595a00000)
        libselinux.so.1 => /lib64/libselinux.so.1 (0x0000003595600000)
        libsepol.so.1 => /lib64/libsepol.so.1 (0x0000003595200000)
        libdl.so.2 => /lib64/libdl.so.2 (0x0000003594200000)
        libncurses.so.5 => /usr/lib64/libncurses.so.5 (0x0000003596a00000)
        libc.so.6 => /lib64/libc.so.6 (0x0000003593e00000)
        /lib64/ld-linux-x86-64.so.2 (0x0000003593a00000)

# rpm -q lvm2-cluster
lvm2-cluster-2.02.40-7.el5
Comment 3 errata-xmlrpc 2009-09-02 07:57:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1394.html

Note You need to log in before you can comment on or make changes to this bug.