Bug 480282 - dvd test won't stop if inserting an empty DVD disk
dvd test won't stop if inserting an empty DVD disk
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: YangKun
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 01:52 EST by lihuang
Modified: 2014-03-25 20:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-16 13:01:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
results.xml (160.86 KB, text/plain)
2009-01-16 03:41 EST, lihuang
no flags Details

  None (edit)
Description lihuang 2009-01-16 01:52:49 EST
Description of problem:
dvd test won't stop if inserting an empty DVD disk


Version-Release number of selected component (if applicable):
hts-5.3-12.el5

How reproducible:
Every time

Steps to Reproduce:
1.#hts plan
2.#hts run -t dvd
3.insert an empty DVD disk
  
Actual results:


Expected results:
dvd test end with a warning

Additional info:
Comment 1 YangKun 2009-01-16 02:41:19 EST
this actually affects both cdrom and dvd tests.

could you please attach the output.log and /var/hts/results.xml file here ?

Thanks
-YK
Comment 2 lihuang 2009-01-16 03:38:56 EST
[root@shangrila ~]# hts print plan
/var/hts

Test Plan:
----------------------------------------------------------------
dvd        hda        storage_model_DV_28E_N               
usb                   pnp_PNP0a03                          
network    eth2       net_00_00_87_e2_c7_69                
network    eth1       net_00_00_87_e2_c7_68                
network    eth0       net_00_00_87_12_b4_b4                
memory                                                     
storage    sda        storage_serial_3500000e01248e7d0     
video                 pci_1002_515e                        
core                                                       
profiler                                                   
info                                                       
[root@shangrila ~]# hts run -t dvd
/var/hts
loaded results /var/hts/results.xml
OS Version: Red Hat Enterprise Linux Server release 5.3 (Tikanga)
Kernel RPM: kernel-2.6.18-128.el5
HTS version 5.3, release 12
saved test plan to /var/hts/results.xml
running only test dvd 
running dvd on /org/freedesktop/Hal/devices/storage_model_DV_28E_N
mkdir -p /tmp/hts-dvd-rwUtKN/mnt/tests/HTS/hts/dvd
cp -a testinfo.desc runtest.sh dvd.py Makefile /tmp/hts-dvd-rwUtKN/mnt/tests/HTS/hts/dvd
install -m 0755 runtest.sh /tmp/hts-dvd-rwUtKN/mnt/tests/HTS/hts/dvd
make OUTPUTFILE=/var/log/hts/runs/1/dvd/output.log RUNMODE=normal UDI=/org/freedesktop/Hal/devices/storage_model_DV_28E_N DEVICE=hda TESTSERVER=unknown run
chmod a+x ./runtest.sh ./dvd.py
./runtest.sh
/tmp/hts-dvd-rwUtKN/mnt/tests/HTS/hts/dvd/dvd.py
Running ./dvd.py:

  Your CD/DVD device /dev/hda supports dvd 
  We will check these features. 
  You need to prepare following media(disks) for this test: 

    --- one DVD data disk which contains more than 800MiB of data. 
        (e.g. one RHEL5 install DVD disk) 

  Press ENTER when you are ready ! Or press Ctrl-C to quit !

  Please insert a DVD data disk into hda and then press ENTER to continue !

  +++ Start testing ... 

umount: /dev/hda: not mounted

  +++ Media mounted !

  Copying files ...
Comment 3 lihuang 2009-01-16 03:41:37 EST
Created attachment 329184 [details]
results.xml

/var/hts/results.xml
Comment 4 YangKun 2009-01-16 04:36:10 EST
re-checked the results. this could not be an error.

If the DVD disk is a blank disk, it could not be mounted correctly by "mount -o ro". 

I checked the media used, turns out to be not empty, but containing huge amount of small files and deep dir hierarchy. 

Please re-test and be patient to wait for longer time, if the indicator LED on the optical drive shows the media is busy, then it's still copying or comparing files.

Thanks
-YK
Comment 5 lihuang 2009-01-16 04:58:08 EST
lihuang-> ykun

OK. I am re-testing, and will update the results later.

thank you very much
Comment 6 lihuang 2009-01-16 13:01:55 EST
yes . spent more than 4 hours to finish this case. it ended successfully.
Can I close it ?

Note You need to log in before you can comment on or make changes to this bug.