Bug 480288 - [PATCH] Packaging improvements
[PATCH] Packaging improvements
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: asciidoc (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
: Patch
: 512635 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 04:11 EST by Fabian Affolter
Modified: 2009-11-01 20:41 EST (History)
6 users (show)

See Also:
Fixed In Version: 8.4.5-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 17:08:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update to 8.4.3 (4.83 KB, patch)
2009-04-17 15:34 EDT, Ville Skyttä
no flags Details | Diff
Packaging improvements (5.56 KB, patch)
2009-07-29 14:56 EDT, Ville Skyttä
no flags Details | Diff
Packaging improvements (7.60 KB, patch)
2009-09-07 18:09 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Fabian Affolter 2009-01-16 04:11:25 EST
There is a new version of asciidoc available.

Latest version :     8.3.3
Version in Fedora :  8.2.5

2 January 2009: AsciiDoc 8.3.3 Released

Two significant changes in this release:

* Included Gouichi Iisaka’s Graphviz filter in the AsciiDoc distribution.
* You can now set the numbered list number style (arabic, loweralpha, upperalpha, lowerroman, upperroman) or let AsciiDoc guess the style of the first numbered item.

Thanks for updating the package.
Comment 1 Fabian Affolter 2009-02-19 04:05:09 EST
Any progress on this?
Comment 2 Fabian Affolter 2009-03-09 11:02:28 EDT
asciiDoc 8.3.5 released
Comment 3 Fabian Affolter 2009-03-19 09:34:14 EDT
AsciiDoc 8.4.2 Released

Version 8.4.2 (2009-03-19)
Additions and changes

    *

      Added testasciidoc, a tool to verify AsciiDoc conformance.
    *

      A warning is issued if nested inline passthroughs are encountered.
    *

      asciidocapi: setting an attribute value to None will undefine (delete) the attribute (this in addition to the name! attribute name format that the asciidoc(1) command uses).
Comment 4 Ville Skyttä 2009-04-17 15:32:36 EDT
8.4.3 is out, will attach a patch.
Comment 5 Ville Skyttä 2009-04-17 15:34:50 EDT
Created attachment 340075 [details]
Update to 8.4.3

- Update to 8.4.3.
- Convert specfile to UTF-8.
- Add dependencies on libxslt and docbook-style-xsl.

Maintainers, let me know if you'd like me to commit and build this to devel (F-12)
Comment 6 Bug Zapper 2009-06-09 06:45:07 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Fabian Affolter 2009-07-29 06:36:32 EDT
asciidoc was updated to 8.4.5

* Fri Jun 19 2009 Dave Airlie <airlied@redhat.com> 8.4.5-1
- new upstream version 8.4.5 - required by X.org libXi to build

The patch from comment #5 was not applied.  Renaming of the bug to reflect that and cc'ed Dave because he made the update and will perhaps add the patch from Ville.
Comment 8 Ville Skyttä 2009-07-29 14:56:47 EDT
Created attachment 355596 [details]
Packaging improvements

Here's an updated patch against latest in CVS/devel at the moment.

- Specfile cleanup, convert it to UTF-8.
- Add dependencies on libxslt and docbook-style-xsl.
- Exclude unneeded *.py[co].
- Install python API.
Comment 9 Ville Skyttä 2009-07-29 14:59:36 EDT
(Further summary editing, assigning to default asciidoc owner instead of nobody.)
Comment 10 Ville Skyttä 2009-09-07 18:05:46 EDT
(Cc'ing Todd who made some of these improvements already in 8.4.5-3.)
Comment 11 Ville Skyttä 2009-09-07 18:09:30 EDT
Created attachment 360022 [details]
Packaging improvements

Here's a patch updated to current rawhide.  Hopefully this one will make it before it needs to be rebased yet again...

As earlier, let me know if you'd like me to commit and build this for Rawhide.  If there's no feedback, I'll go ahead some time before F-12 assuming the ACLs allow it.
Comment 12 Ville Skyttä 2009-09-17 17:08:11 EDT
Committed and built for Rawhide as 8.4.5-4.fc12.
Comment 13 Ville Skyttä 2009-09-17 17:11:42 EDT
*** Bug 512635 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.