Bug 480348 - No module named _sha256
No module named _sha256
Status: CLOSED DUPLICATE of bug 480312
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 11:01 EST by Jóhann B. Guðmundsson
Modified: 2014-01-21 18:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-16 11:59:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2009-01-16 11:01:38 EST
Description of problem:

After updating to today's rawhide yum fails with this.. 

There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   No module named _sha256

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.5.2 (r252:60911, Sep 30 2008, 15:42:03) 
[GCC 4.3.2 20080917 (Red Hat 4.3.2-4)]

If you cannot solve this problem yourself, please go to 
the yum faq at:
  http://wiki.linux.duke.edu/YumFaq
  


Version-Release number of selected component (if applicable):

20-5

How reproducible:

Always

Steps to Reproduce:
1. yum <enter>
2.
3.
  
Actual results:

The above 

Expected results:

Yum being functional..

Additional info:
Comment 1 James Antill 2009-01-16 11:03:02 EST
openssl updated and broke ABI ... do the symlink thing to work around it (see f-d-l).
Comment 2 seth vidal 2009-01-16 11:18:43 EST
reassigning to openssl and reopening.
Comment 3 Jóhann B. Guðmundsson 2009-01-16 11:45:55 EST
The symbolic link for libcrypto.so.7 was missing

Simple ln -s /lib64/libcrypto.so.8 /lib64/libcrypto.so.7 Fixed this for me

There where other things that broke as well for like cups sendmail  and more

Did not keep track of it all fixed after creating the symbolic link..
Comment 4 Tomas Mraz 2009-01-16 11:59:06 EST

*** This bug has been marked as a duplicate of bug 480312 ***

Note You need to log in before you can comment on or make changes to this bug.