Bug 480349 - Gnome freeze with Firefox
Gnome freeze with Firefox
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 11:02 EST by Emanuele Bellini
Modified: 2014-06-10 10:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-23 13:01:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
manubellini87: needinfo-


Attachments (Terms of Use)
Output of requested RPM command (1.03 KB, text/plain)
2009-01-19 16:44 EST, Emanuele Bellini
no flags Details
GDB real-time output (3.05 KB, text/plain)
2009-01-20 16:24 EST, Emanuele Bellini
no flags Details
screenshot of non-reproduction (271.77 KB, image/png)
2009-01-21 08:06 EST, Matěj Cepl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 475043 None None None Never

  None (edit)
Description Emanuele Bellini 2009-01-16 11:02:46 EST
Description of problem:
About a year ago I registered a new Yahoo! account and received a welcome e-mail in the new e-mail address. Now I wanted to see what's there, but I can't see that because my computer freezes every time Firefox begins to load the message. The mouse usually stops working and if it works I can't click on anything, I can't restart Gnome so I have to "manually" reboot.
It also happened in another websites, but I was thinking it was an isolated case.
Obviously, I don't want Firefox to work, I want to close it! Or should I?


Version-Release number of selected component (if applicable):
firefox-3.0.5-1.fc10


How reproducible:
Always with that e-mail!


Actual results:
I can't load the e-mail because my system freezes. I have to reboot powering off.


Expected results:
I want to close Firefox!

Additional info:
I have several plug-ins for Firefox, so I've tried the safe-mode.
I had the same issue with the Metacity compositor enabled with many websites, but you told me I shouldn't use it, so I turned it off.
Comment 1 Matěj Cepl 2009-01-19 08:00:24 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

Please also install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of gdb debugger. Then use command run and do whatever you did to make firefox crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Emanuele Bellini 2009-01-19 16:44:12 EST
Created attachment 329399 [details]
Output of requested RPM command
Comment 3 Matěj Cepl 2009-01-19 19:37:50 EST
and backtrace?
Comment 4 Emanuele Bellini 2009-01-20 16:12:32 EST
I've found another "public" site to make Firefox crash; so what I have to do is:

1)go to www.labmacs.diiga.univpm.it;
2)click on "Courses";
3)reboot.

Now I have the backtrace (I kept the Needinfo flag set), but it isn't interesting at all: it simply says "No registers.".
I tried to see what gdb writes, but before the bad click many threads are launched and closed, after that nothing happens. (if you want, I have the entire incoming/outgoing process list, but I don't think it may be helpful).
Anyway, I'm going to attach a file with the gdb output before the run command.
What can I do now?
Comment 5 Emanuele Bellini 2009-01-20 16:24:31 EST
Created attachment 329504 [details]
GDB real-time output

I've added two comments in C-style!
This time I didn't need to click on Courses to make Firefox crash, it's strange because other times I waited but it didn't.
Comment 6 Matěj Cepl 2009-01-21 08:06:16 EST
Created attachment 329599 [details]
screenshot of non-reproduction

Cannot reproduce -- the website looks awful, but firefox doesn't crash. Are you able to reproduce the issue with

a) firefox -safe-mode
b) upstream binary from http://www.mozilla.com

?
Comment 7 Emanuele Bellini 2009-01-21 16:05:27 EST
I've tried both, but the problem isn't solved. Moreover, I tried to delete my Firefox settings folder in my home, but it doesn't change anything.
Comment 8 Matěj Cepl 2009-01-21 17:14:49 EST
(In reply to comment #7)
> I've tried both, but the problem isn't solved.

Meaning, you were able to reproduce this with upstream binary?
Comment 9 Emanuele Bellini 2009-01-22 08:48:20 EST
Yes, of course. I've downloaded the Linux version from the site above, but I still have the same issue (in safe mode).
Comment 10 Matěj Cepl 2009-01-23 13:01:27 EST
We filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=475043) and believe that it is more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.
Comment 11 Matěj Cepl 2010-10-07 09:59:40 EDT
Reporter, there is a request for needinfo in the upstream bug. Could you please reply to it either there or (if you don't have an account on bugzilla.mozilla.org) at least here?

Thank you

Note You need to log in before you can comment on or make changes to this bug.