This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 480352 - Please let us know how to fix this issue. Thanks!
Please let us know how to fix this issue. Thanks!
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.2
x86_64 Linux
low Severity urgent
: rc
: ---
Assigned To: James Antill
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 11:29 EST by cecil lee
Modified: 2013-03-12 16:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 16:26:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Error Log (2.17 KB, application/octet-stream)
2009-11-05 07:58 EST, Feddin
no flags Details

  None (edit)
Description cecil lee 2009-01-16 11:29:33 EST
Description of problem:


Component: pirut
Summary: TB3518121c rpcServer.py:168:getServer:SSLCertificateFileNotFound: ERROR: can not find RHNS CA file: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 490, in ?
    main()
  File "/usr/sbin/pirut", line 483, in main
    pm = PackageManager(options.config, options.onlyrepo)
  File "/usr/sbin/pirut", line 67, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 137, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 118, in doConfigSetup
    errorlevel=errorlevel)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 183, in _getConfig
    self.plugins.run('init')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rhnplugin.py", line 109, in init_hook
    login_info = up2dateAuth.getLoginInfo()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 211, in getLoginInfo
    login()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 162, in login
    server = rhnserver.RhnServer()
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 147, in __init__
    self._server = rpcServer.getServer()
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 168, in getServer
    raise up2dateErrors.SSLCertificateFileNotFound(msg)
SSLCertificateFileNotFound: ERROR: can not find RHNS CA file: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT

Local variables in innermost frame:
lang: en_US
rhns_ca_cert: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
log: <up2date_client.up2dateLog.Log instance at 0x1422eef0>
proxyUser: None
cfg: <up2date_client.config.Config instance at 0x1422eea8>
ca: ['/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT']
rhns_ca_certs: ['/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT']
proxyPassword: None
proxyHost: None
s: <RetryServer for /XMLRPC>
refreshCallback: None
serverUrls: ['https:///XMLRPC']
env: LANG
msg: ERROR: can not find RHNS CA file: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
serverList: <up2date_client.rpcServer.ServerList instance at 0x1422ee18>
Comment 1 Feddin 2009-11-05 07:58:50 EST
Created attachment 367607 [details]
Error Log
Comment 2 James Antill 2013-03-12 16:26:03 EDT
 Looks like the rhnplugin installation is bad. Reinstalling those packages should fix it (although that's hard given that you won't be able to contact the RHN servers).

Note You need to log in before you can comment on or make changes to this bug.