Bug 480382 - Re-enable Schema Upgrades in Satellite 5.3 ISOs
Re-enable Schema Upgrades in Satellite 5.3 ISOs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Milan Zazrivec
Steve Salevan
:
: 476015 (view as bug list)
Depends On:
Blocks: 463876
  Show dependency treegraph
 
Reported: 2009-01-16 14:39 EST by Devan Goodwin
Modified: 2009-09-10 14:53 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:53:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2009-01-16 14:39:31 EST
After transitioning the satellite-schema content from svn RELEASE-5.3 branch into new Satellite git, the upgrade scripts there will not build properly and I had to disable them. I'm not fully clear on how the whole upgrade process hangs together so will need someone familiar with it to take a look and get it into a state they're happy with for the long term.

Problem appears to be related to the use of symlinks for the upgrade script directories, which the build tools then try to convert to a patch on top of Spacewalk schema and this process fails.

This content is currently not packaged in the rpms and will need to be re-enabled.
Comment 1 Milan Zazrivec 2009-01-20 14:07:51 EST
*** Bug 476015 has been marked as a duplicate of this bug. ***
Comment 2 Milan Zazrivec 2009-01-20 14:18:05 EST
Fixed in satellite.git (SATELLITE-5.3 branch):

0e0de392b331184d08cc639bc23341c4590312c0
f8d96aa5fb4eba9630ac5888e2532d4fc4d38f2e
c677ce711a7df6cf87ef819cf925a63d38563294
146a5a398a050f35c55f64b16c9c91b2f0422909
f81c11e828ecf5fa35a1a897e45135d19ff1726c
37b200c8feaad11b3d18fe4f3ac28e1388fb2441
729cc1d39371a95f47aad4584656fa72a7f8081d
0e967dd743f937e1f9d0e39a98b044ed5efd0d4b

Tagged satellite-schema-5.3.0.5-1-sat
Built satellite-schema-5.3.0.5-1.el5sat & satellite-schema-5.3.0.5-1.el4sat
Comment 3 Milan Zazrivec 2009-01-20 14:38:33 EST
(In reply to comment #2)
> Tagged satellite-schema-5.3.0.5-1-sat
> Built satellite-schema-5.3.0.5-1.el5sat & satellite-schema-5.3.0.5-1.el4sat

Correct package versions are satellite-schema-5.3.0.6-1.el5sat
and satellite-schema-5.3.0.6-1.el4sat.
Comment 4 Steve Salevan 2009-04-08 13:33:38 EDT
satellite-schema packages present and schema-upgrade directories present in latest 530 builds.  Moving to VERIFIED, tested on 530-re20090403.2
Comment 5 Michael Mráka 2009-08-07 05:12:22 EDT
Verified in stage -> RELEASE_PENDING.

# rpm -qa *schema
spacewalk-schema-0.5.20-19.el4sat
satellite-schema-5.3.0.23-1.el4sat
# rpm -qla *schema | grep satellite-schema-5.3 | wc -l
13
Comment 6 Brandon Perkins 2009-09-10 14:53:50 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.