This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 4804 - man 5 exports includes link_relative -- exportfs refuses it
man 5 exports includes link_relative -- exportfs refuses it
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-31 10:46 EDT by jonathan
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-09 10:50:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jonathan 1999-08-31 10:46:38 EDT
The use of the link_relative keyword in /etc/exports
no longer works (it did in RH 5.2).  Yet the man page for
exports still refers to this keyword.

Either the manpage should be altered to remove the text
about this option, or else knfsd and exportfs need to be
taught to make use of it once more.

Jonathan Marsden <jonathan@xc.org>
Comment 1 jonathan 1999-08-31 10:49:59 EDT
This problem remains in knfsd-1.4.7-2 in Rawhide.

Jonathan Marsden <jonathan@xc.org>
Comment 2 Cristian Gafton 2000-08-08 22:34:57 EDT
assigned to johnsonm
Comment 3 jonathan 2000-08-09 10:50:11 EDT
I think Red Hat's bug tracking has let it down somehow.
This problem was reported a year ago for RH 6.0.
It was long since fixed (in 6.1 or 6.2, I forget which).
Yet now it is being assigned as a Pinstripe Beta bug?  Why?

I recommend this be closed as fixed.
The link_relative keyword is no longer in the man 5 exports page.

Jonathan Marsden <jonathan@xc.org>
Comment 4 Karsten Hopp 2000-08-14 08:32:40 EDT
link_relative is no longer supported. The reference in the manpage
has been removed

Note You need to log in before you can comment on or make changes to this bug.