Bug 480421 - NetworkManager-0.7.0-1.git20090102.fc10 no longer bring up system interfaces without an NM_CONTROLLED=yes entry
NetworkManager-0.7.0-1.git20090102.fc10 no longer bring up system interfaces ...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 17:58 EST by Orion Poplawski
Modified: 2009-02-06 12:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-06 12:49:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2009-01-16 17:58:47 EST
Description of problem:

NetworkManager-0.7.0-1.git20090102.fc10 will no longer bring up system interfaces without an NM_CONTROLLED=yes entry, causing much grief for server type machines.

Jan 16 12:34:41 kolea nm-system-settings:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-eth0 ...
Jan 16 12:34:41 kolea nm-system-settings:    ifcfg-rh:     read connection 'System eth0'

Jan 16 12:34:44 kolea NetworkManager: <info>  (eth0): device state change: 1 -> 2
Jan 16 12:34:44 kolea NetworkManager: <info>  (eth0): bringing up device.
Jan 16 12:34:45 kolea kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready
Jan 16 12:34:45 kolea NetworkManager: <info>  (eth0): preparing device.
Jan 16 12:34:45 kolea NetworkManager: <info>  (eth0): deactivating device (reason: 2).
Jan 16 12:34:45 kolea NetworkManager: <info>  (eth0): carrier now ON (device state 2)
Jan 16 12:34:45 kolea NetworkManager: <info>  (eth0): device state change: 2 -> 3
Jan 16 12:34:45 kolea NetworkManager: <info>  (eth0): carrier now OFF (device state 3)
Jan 16 12:34:45 kolea NetworkManager: <info>  (eth0): device state change: 3 -> 2
Jan 16 12:34:45 kolea NetworkManager: <info>  (eth0): deactivating device (reason: 40).
Jan 16 12:34:45 kolea NetworkManager: <WARN>  auto_activate_device(): Connection
'System eth0' auto-activation failed: (2) Device not managed by NetworkManager

# cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:13:d3:f7:f6:e0
ONBOOT=yes
SEARCH="cora.nwra.com"
Comment 1 Dan Williams 2009-02-05 13:17:06 EST
Hmm, this is not right.  Just to narrow down a few things; the HWADDR shown there is the same as the mac address on eth0, right?

Also, what's the output of this:

dbus-send --print-reply --system --dest=org.freedesktop.NetworkManagerSystemSettings /org/freedesktop/NetworkManagerSettings org.freedesktop.DBus.Properties.Get string:org.freedesktop.NetworkManagerSettings.System string:UnmanagedDevices
Comment 2 Orion Poplawski 2009-02-06 12:49:04 EST
Hmm, I cannot reproduce this any more.  No idea what was going on.

Note You need to log in before you can comment on or make changes to this bug.