Bug 480431 - Satellite 5.2 embedded installation on RHEL 4.6 i386 fails during database installation (4.7 "stops", 4.5 succeeds)
Satellite 5.2 embedded installation on RHEL 4.6 i386 fails during database in...
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
520
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Brandon Perkins
: Regression
Depends On:
Blocks: 468734
  Show dependency treegraph
 
Reported: 2009-01-16 20:11 EST by Xixi
Modified: 2009-04-15 01:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 02:25:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xixi 2009-01-16 20:11:38 EST
Description of problem:
With the newest Sat 5.2 i386 RHEL 4 embedded iso, installation on RHEL 4 U6 client fails at database step, for details see below.

Version-Release number of selected component (if applicable):
5.2.0 Satellite

How reproducible:
Always.

Steps to Reproduce:
1. Kickstart a 32bit RHEL 4 client to u6.
2. Download GA iso Satellite-5.2.0-RHEL4-re20081028.3-i386-embedded-oracle.iso from https://rhn.redhat.com/rhn/software/channel/downloads/Download.do?cid=8738
3. mount -o loop iso, cd into mount directory and run ./install.pl, wait.
  
Actual results:
Installer runs fine til it fails at database installation step -
...
* Setting up database.
** Database: Installing the embedded database (not the schema).
** Database: Shutting down the database first.
** Database: Installing the database:
** Database: This is a long process that is logged in:
** Database:   /var/log/rhn/install_db.log
*** Progress: ######################Could not install database.
...
and /var/log/rhn/install_db.log shows near the end:
SQL> SQL> SQL>
SQL> SQL>
SCRIPT
-----------------------
rdbms/admin/catproc.sql
SQL> SQL> O/S Message: No such file or directory
Disconnected from Oracle Database 10g Enterprise Edition Release 10.2.0.4.0 - Production
With the Partitioning, OLAP, Data Mining and Real Application Testing options

Expected results:
That it succeeds to install.

Additional info:
Have not tried other arch/OS releases.
Comment 2 Xixi 2009-01-17 00:08:49 EST
Further information:

With RHEL4 *U7*, the installation stops at the same place - only instead of failing with error as in U6, it stops (no further progress after 3 hours so far), as seen both by mmccune and myself:

From cmdline:
...
** Database: Installing the embedded database (not the schema).
** Database: Shutting down the database first.
** Database: Installing the database:
** Database: This is a long process that is logged in:
** Database:   /var/log/rhn/install_db.log
*** Progress: #####################

From var/log/rhn/install_db.log:
...
SQL> SQL> SQL>
SQL> SQL>
SCRIPT
-----------------------
rdbms/admin/catproc.sql

SQL> SQL>

With RHEL 4 *U5*, it installed to completion.
Comment 3 Jan Pazdziora 2009-01-19 06:11:24 EST
Adding Michael to Cc (we might reassign this bugzilla to him eventually).
Comment 4 Jan Pazdziora 2009-01-19 06:15:05 EST
Xixi,

can you confirm that in the log, the preceding lines look like

-----------------------
rdbms/admin/catalog.sql

SQL> SQL> SQL> 
SQL> SQL> 
SCRIPT
------------------------
rdbms/admin/catblock.sql

SQL> SQL> SQL> 
SQL> SQL> 
SCRIPT
-----------------------
rdbms/admin/catproc.sql

?

What does

ls -la /opt/apps/oracle/web/product/10.2.0/db_1/rdbms/admin/{catalog,catblock,catproc}.sql

show?
Comment 5 Xixi 2009-01-19 15:32:17 EST
(In reply to comment #4)
Hi Jan,

Sorry, unfortunately, we had to re-kickstart that machine for a reproducer (I ran into this bug during the setting up of said reproducer). I do recall doing a ls to make sure that /opt/apps/oracle/web/product/10.2.0/db_1/rdbms/admin/catproc.sql indeed existed, however.

mmccune has a guest with rhel4u7 we can probably still look into - test13-64 - however he mentioned for some reason can't get into the guests right now.  If that's resolved you can ssh in and take a peek.  If all else fails, we can get another box to repro this again.

Let me know,

Xixi
Comment 6 Xixi 2009-01-21 20:47:18 EST
Update -

Borrowed guest (thanks mmccune) to re-try the same RHEL4U6 install on dhcp77-175 as described in bug summary.  This time there was no failure and installation succeeded as expected.  Odd...  

If no one else is able to reproduce again either, I think we can close this bug.
Thanks,

Xixi
Comment 7 Jan Pazdziora 2009-01-22 02:25:33 EST
Thanks for the note.

The version / update of RHEL should really not have any impact on Oracle being able or not able to find the file.

Closing now, feel free to reopen or file another bugzilla if the problem reoccurs.
Comment 8 shane 2009-04-13 12:00:31 EDT
I think I am having this problem as well.  RHEL4u7 x86_64 Satellite 5.2 x86_64

I ran the install.pl and it sits there here..  (left it for quite some time)

--- from install output ---
* Setting up database.
** Database: Installing the embedded database (not the schema).
** Database: Shutting down the database first.
** Database: Installing the database:
** Database: This is a long process that is logged in:
** Database:   /var/log/rhn/install_db.log
*** Progress: #######################

--- log file ---
Disconnected from Oracle Database 10g Enterprise Edition Release 10.2.0.4.0 - 64bit Production
With the Partitioning, OLAP, Data Mining and Real Application Testing options
Adding 'rhnsat' entry to /etc/oratab
+ LISTFILE=/opt/apps/oracle/web/product/10.2.0/db_1/network/admin/listener.ora
+ cat
+ chown oracle:dba /opt/apps/oracle/web/product/10.2.0/db_1/network/admin/listener.ora
+ chkconfig --add rhn-database
+ service rhn-database restart
Shutting down rhn-database:                                [FAILED]
Starting rhn-database:                                     [  OK  ]
+ set +x


--- some ps listings ---
$: ps aux | egrep -i ora\|http\|sate\|install

root     21524  0.0  1.2 189960 24732 pts/0  S+   10:20   0:00 /usr/bin/perl ./install.pl
oracle   21669  0.0  0.4 44900 9776 ?        Ss   10:20   0:00 /opt/apps/oracle/web/product/10.2.0/db_1/bin/tnslsnr LISTENER -inherit
root     21877  0.0  0.0 53752  580 pts/1    S+   10:29   0:00 tail -f //var/log/rhn/install_db.log
oracle   22093  0.0  0.8 405660 18248 ?      Ss   10:35   0:00 ora_pmon_rhnsat
oracle   22095  0.0  0.7 404488 16088 ?      Ss   10:35   0:00 ora_psp0_rhnsat
oracle   22097  0.0  1.9 404496 39332 ?      Ss   10:35   0:00 ora_mman_rhnsat
oracle   22099  0.0  3.0 408500 63000 ?      Ss   10:35   0:00 ora_dbw0_rhnsat
oracle   22101  0.0  2.4 406964 50156 ?      Ss   10:35   0:00 ora_dbw1_rhnsat
oracle   22103  0.1  1.1 420048 24252 ?      Ss   10:35   0:01 ora_lgwr_rhnsat
oracle   22105  0.0  1.1 405076 24336 ?      Ss   10:35   0:00 ora_ckpt_rhnsat
oracle   22107  0.0  2.7 406156 55556 ?      Ss   10:35   0:00 ora_smon_rhnsat
oracle   22109  0.0  1.2 405068 25424 ?      Ss   10:35   0:00 ora_reco_rhnsat
oracle   22111  0.1  2.1 407236 44652 ?      Ss   10:35   0:01 ora_cjq0_rhnsat
oracle   22113  0.0  2.8 407336 58412 ?      Ss   10:35   0:00 ora_mmon_rhnsat
oracle   22115  0.0  1.1 404536 23796 ?      Ss   10:35   0:00 ora_mmnl_rhnsat
oracle   22121  0.0  1.1 404552 23152 ?      Ss   10:35   0:00 ora_qmnc_rhnsat
oracle   22161  0.0  1.1 404568 24512 ?      Ss   10:35   0:00 ora_q000_rhnsat
oracle   22209  0.0  0.8 404520 16860 ?      Ss   10:36   0:00 ora_q001_rhnsat
Comment 9 Jan Pazdziora 2009-04-14 08:11:23 EDT
Please note that this bugzilla was about message

rdbms/admin/catproc.sql
SQL> SQL> O/S Message: No such file or directory

while your installation seems to have gone just fine util the final restart of the rhn-database service.

Or do you also have the "No such file or directory" error in the log?
Comment 10 shane 2009-04-15 01:51:48 EDT
no i have rhel4u7 with satellite 5.2 and it would just hang.

i finally ctrl+c it and then reran the install.pl --skip-db-test or some switch like that and it worked.  asked if I wanted to clean the db I said yes it completed and seems to be working.
Comment 11 shane 2009-04-15 01:57:01 EDT
oh yea i think the problem was the ownership of a file was wrong ...


/etc/rhn/rhn.conf  was root:root 640 and the db couldn't start.  I ran `chmod o+r /etc/rhn/rhn.conf` and then the db would start.  I didn't try to reinstall but then the --skip-db-test switch worked.

Note You need to log in before you can comment on or make changes to this bug.