Bug 480499 - Sound lag problems with pulseaudio
Sound lag problems with pulseaudio
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
: 489339 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-17 16:02 EST by Eddie Lania
Modified: 2009-04-23 18:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 18:17:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eddie Lania 2009-01-17 16:02:42 EST
Description of problem: In Fedora 10 I experience sound lag problems in flash player when playing flash games or watching movies.


Version-Release number of selected component (if applicable):

pulseaudio-utils-0.9.14-1.fc10.i386
pulseaudio-libs-0.9.14-1.fc10.i386
pulseaudio-module-gconf-0.9.14-1.fc10.i386
alsa-plugins-pulseaudio-1.0.18-2.fc10.i386
projectM-pulseaudio-1.2.0-3.fc10.i386
pulseaudio-core-libs-0.9.14-1.fc10.i386
pulseaudio-module-jack-0.9.14-1.fc10.i386
pulseaudio-libs-zeroconf-0.9.14-1.fc10.i386
xine-lib-pulseaudio-1.1.16-1.fc10.i386
pulseaudio-esound-compat-0.9.14-1.fc10.i386
pulseaudio-module-zeroconf-0.9.14-1.fc10.i386
pulseaudio-0.9.14-1.fc10.i386
pulseaudio-libs-glib2-0.9.14-1.fc10.i386
akode-pulseaudio-2.0.2-5.fc9.i386
pulseaudio-module-x11-0.9.14-1.fc10.i386
flash-plugin-10.0.15.3-release.i386


How reproducible: Play a flash movie on youtube or play a flash game somewhere on the internet.


Steps to Reproduce:
1.Install Fedora 10
2.Install flash
3.Play a flash movie or game.
  
Actual results:
The sound is lagging in the movie or game.


Expected results:
No sound lag.


Additional info:

I was able to solve this in fedora 8/0 by creating a ~./asoundrc file with the following contents:

pcm.!default {
type plug
slave.pcm "dmixer"
}

pcm.dmixer {
type dmix
ipc_key 1025
slave {
pcm "hw:0,0"
period_time 0
period_size 2048
buffer_size 8192
rate 48000
}
bindings {
0 0
1 1
}
}

However, now in fedora 10 this doesn't work anyomore.
Comment 1 Matthew 2009-03-09 14:10:19 EDT
Do you see the lag right away? I mean, from the very beginning is it like .2 seconds off or does it start off synchronized and slowly drift?

For me I see it slowly drift out of synch, this is mostly observed with xine/miro.
Comment 2 Eddie Lania 2009-03-09 14:29:24 EDT
When I open for instance http://onslaught.playr.co.uk/ in firefox and wait for the game to begin then the sounds of the first rockets being fired by the turret are still in sync but right after that is starts falling behind. The lag is however constant just a little behind the animations.

This is the same with every game. Like the gambling (fruitmachines) on http://www.slotplaza.com/

Playing video on for example youtube changes from video to video. The lag is almost never constant. Sometimes it is in sync, sometimes it is not.

Regards,

Eddie.
Comment 3 Lennart Poettering 2009-04-03 12:28:52 EDT
*** Bug 489339 has been marked as a duplicate of this bug. ***
Comment 4 Lennart Poettering 2009-04-23 18:17:51 EDT
This is brokeness in Flash. PA provides correct timing information to applications via snd_pcm_delay() and similar calls.

Please open a bug against Flash. 

Closing now, feel free to reopen, if you manage to reproduce this issue with open source software!

Note You need to log in before you can comment on or make changes to this bug.