Bug 480507 - Crashes on startup
Crashes on startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pitivi (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-17 17:50 EST by Denis Leroy
Modified: 2009-01-17 21:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-17 21:20:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Variable rename patch (1.14 KB, patch)
2009-01-17 18:32 EST, Denis Leroy
no flags Details | Diff

  None (edit)
Description Denis Leroy 2009-01-17 17:50:58 EST
Doesn't seem to be working currently on rawhide. Crashes on startup with the following error:

> pitivi
Traceback (most recent call last):
  File "/usr/bin/pitivi", line 122, in <module>
    _run_pitivi()
  File "/usr/bin/pitivi", line 111, in _run_pitivi
    import pitivi.pitivi as ptv
  File "/usr/share/pitivi/python/pitivi/pitivi.py", line 33, in <module>
    from project import Project, file_is_project
  File "/usr/share/pitivi/python/pitivi/project.py", line 29, in <module>
    from timeline.timeline import Timeline
  File "/usr/share/pitivi/python/pitivi/timeline/timeline.py", line 198
    as = self.audiocomp._getAutoSettings()
     ^
SyntaxError: invalid syntax
Comment 1 Jeffrey C. Ollie 2009-01-17 18:10:00 EST
(In reply to comment #0)
> Doesn't seem to be working currently on rawhide. Crashes on startup with the
> following error:
> 
> > pitivi
> Traceback (most recent call last):
>   File "/usr/bin/pitivi", line 122, in <module>
>     _run_pitivi()
>   File "/usr/bin/pitivi", line 111, in _run_pitivi
>     import pitivi.pitivi as ptv
>   File "/usr/share/pitivi/python/pitivi/pitivi.py", line 33, in <module>
>     from project import Project, file_is_project
>   File "/usr/share/pitivi/python/pitivi/project.py", line 29, in <module>
>     from timeline.timeline import Timeline
>   File "/usr/share/pitivi/python/pitivi/timeline/timeline.py", line 198
>     as = self.audiocomp._getAutoSettings()
>      ^
> SyntaxError: invalid syntax

I believe this is because "as" is a reserved word in Python 2.6 where it wasn't before.  I looked at the upstream Git repo and I didn't see an easy patch to pull out and apply against the current release.  I don't know enough about the pitivi code to put together a patch in a reasonable amount of time.  Can you report this upstream and see if they have an easy patch or if there's a new release due out soon?
Comment 2 Denis Leroy 2009-01-17 18:32:32 EST
Created attachment 329293 [details]
Variable rename patch

Looks like simply renaming the variable name does the trick. Patch attached.
Comment 3 Jeffrey C. Ollie 2009-01-17 21:20:30 EST
New build should appear in tomorrow's rawhide:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1063118

Note You need to log in before you can comment on or make changes to this bug.