Bug 480517 - upgrade fc9 to fc10 removings networking
upgrade fc9 to fc10 removings networking
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-17 22:23 EST by Ray Todd Stevens
Modified: 2014-03-16 23:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 15:39:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2009-01-17 22:23:43 EST
I have seen this one several times now on upgrades both preupgrade and boot disk based.

Essentially when you upgrade all of the networking information is saved, BUT the link to /etc/init.d/network is turned off (K prefix) in rc5.d.

There is a separate problem where the virtual interfaces (eth0:1 etc) are turned from a status of loading when the primary adapter loads the the mode where they are turned off, but any user can turn them on through the network manager thing. Prior to the upgrade they had been set to non network manager no user control.

This ends up breaking other things during the upgrade.
Comment 1 Chris Lumens 2009-01-22 11:34:56 EST
I believe this is intentional - we have switched to using NetworkManager as the default service for controlling networking.  However, since anaconda doesn't do anything with enabling/disabling services (unless you explicitly tell it to via kickstart), I'm going to reassign this to initscripts for further explanation.
Comment 2 Bill Nottingham 2009-01-22 12:27:22 EST
Nothing on upgrade should change the status of networking; it should remain enabled if it was enabled before, and disabled if it was disabled before.

Fedora 9 shipped with NetworkManager enabled by default and network disabled, so an upgrade without any settings changed, it should stay that way.
Comment 3 Ray Todd Stevens 2009-01-22 15:10:14 EST
Well updates are definitely doing nasty things to the network settings.

Frankly I can see using networkmanager by default as a part of a new install, but these are all upgrades.   Upgrade should leave a machine with the same (or better) functionality.   If this can be done in some manner by switching all of the functionality to network manager it seems silly, but OK.   But in this case it leaves a machine that must be physically interacted with.   This appears to happen earily on in the install process, as several of the other packages when they install their update detect that no network interfaces are available and redo their configurations around this fact.   So recovery from this problem can take a couple of hours, even once you find the problem.
Comment 4 Bill Nottingham 2009-01-22 15:29:56 EST
(In reply to comment #3)
> Frankly I can see using networkmanager by default as a part of a new install,
> but these are all upgrades.   Upgrade should leave a machine with the same (or
> better) functionality.   If this can be done in some manner by switching all of
> the functionality to network manager it seems silly, but OK.   But in this case
> it leaves a machine that must be physically interacted with.

OK, what version of initscripts and NetworkManager do you have installed before the upgrade, and what is their state? Similarly, what do they look like afterwards?

> This appears to
> happen earily on in the install process, as several of the other packages when
> they install their update detect that no network interfaces are available and
> redo their configurations around this fact.

Do you have an example of such a package?
Comment 5 lexual 2009-03-03 19:54:05 EST
Can the reporter please provide answers to Bill's questions?
Comment 6 Ray Todd Stevens 2009-03-03 20:58:02 EST
Interesting I didn't see this one go to need info.

It might be hard to find this information.   Obviously this happens during the upgrade, and I am kind of more or less done upgrading.

I will try and answer these from memory.

I don't know that I had network manager even installed before the upgrade.   I certainly never had used it.   There is certainly close to no use for it in this environment.    These are standalone servers.   Network Manager seems to be for systems that require some form of network setting changes on a regular basis. Our setting never change.   They are static ips.    If network manager was loaded it certainly was disabled on all interfaces.

My procedure for doing the upgrade is to do the software update on the machine just before the update.   Well the day before.  Then run preupgrade, and then reboot and upgrade.   I filed this report after this problem had occurred with the third system I upgraded.   So the versions would have been the ones active about on 1/16 if that helps at all.

I don't remember which packages I had problems with.   But I do remember that when I looked into the problems the documentations for these packages said that if no network interfaces were available then they would install in the manner that they did, which was wrong.   

As far as what I ended up with as init scripts, it kind of is what is above.   That is with one exception.   I don't know why it didn't get mentioned at all, but I had a problem with the primary entries too.   That is eth0 eth1 etc.   These were also turned from network manager off to network manager on, and then set for no automatic load.

I guess if you are going to switch over the the network manager thing this is fine, but then if an interface is set to no management by network manager, network manager should bring up the system in the same functionality.
Comment 7 Bill Nottingham 2009-03-24 15:39:22 EDT
I attempted to reproduce this.

I installed Fedora 9. I did:

chkconfig --level 345 NetworkManager off
chkconfig --level 345 network on

I upgraded to the latest F9 updates.

I then upgraded to F10.

At the end of that upgrade, network was still enabled, and NetworkManager was still disabled. Hence, I'm closing this; I can't reproduce it.
Comment 8 Ray Todd Stevens 2009-03-24 16:23:27 EDT
Yeah I have tried to reproduce it too.   Frankly it is highly possible that one of the updates since I had the problem fixed the problem. especially since I know that at least two of these updates dealt with bugs that I had other places in the network configs going to strange statuses.

A couple of things that might be involved if it still exists is that these servers are old enough that the partitions for /boot are 100 meg so you have to have network access during the upgrade to run the upgrade.   To do this I needed to plug the server in differently and use a different set of network settings as the static ips have not worked for preupgrade until recently and still don't work real well.

Note You need to log in before you can comment on or make changes to this bug.