Bug 480539 - mkinitrd-6.0.74 breaks boot of system with / on lvm over software raid, ok with mkinitrd-6.0.73
mkinitrd-6.0.74 breaks boot of system with / on lvm over software raid, ok wi...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-18 11:05 EST by John Ellson
Modified: 2009-01-19 09:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-19 09:15:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2009-01-18 11:05:16 EST
Description of problem:
Boot fails.  Can't find /

Version-Release number of selected component (if applicable):
mkinitrd-6.0.74-1
nash-6.0.74-1
libbdevid-python-6.0.74-1, 
grubby-6.0.74-1
kernel-2.6.29-0.41.rc2

How reproducible:
100%

Steps to Reproduce:
1.update to mkinitrd-6.0.74 and related packages
2.reboot
3.
  
Actual results:
boot fails

Expected results:


Additional info:
Reverting to:
    mkinitrd-6.0.73-7
    nash-6.0.73-7
    libbdevid-python-6.0.73-7
    grubby-6.0.73-7
and re-running mkinitrd fixes the problem.

Diffing the two initrds shows only:
    Binary files GOOD/sbin/nash and BAD/sbin/nash differ
    Binary files GOOD/usr/lib64/libbdevid.so.6.0.73 and BAD/usr/lib64/libbdevid.so.6.0.73 differ
    Binary files GOOD/usr/lib64/libnash.so.6.0.73 and BAD/usr/lib64/libnash.so.6.0.73 differ
so the problem maybe in nash or libbdevid rather than in mkinitrd itself.


My /etc/fstab contains:
    /dev/VolGroup00/LogVol01 /	ext3	defaults,noatime 1	1
    LABEL=/boot		/boot	ext3	defaults,noatime 1	2
    /dev/devpts		/dev/pts	devpts	gid=5,mode=620	0	0
    /dev/shm		/dev/shm	tmpfs	defaults	0	0
    /dev/proc		/proc	proc	defaults	0	0
    LABEL=/pub		/pub	ext3	defaults,noatime 1	2
    /dev/sys		/sys	sysfs	defaults	0	0
    /dev/VolGroup00/LogVol00 swap	swap	defaults	0	0
    none			/var/lib/jack/tmp tmpfs	defaults 0	0
Comment 1 Warren Togami 2009-01-19 00:50:47 EST
According to git, the only change from 73 to 74 is minor changes related to plymouth.  Are you sure you changed nothing else since mkinitrd ran previously?
Comment 2 John Ellson 2009-01-19 09:15:20 EST
OK, there must be something else involved.  I was unable to reintroduce the problem by re-upgrading to latest mkinitrd, rerunning, and rebooting.

Withdrawing...

Note You need to log in before you can comment on or make changes to this bug.