Bug 480540 - Transaction errors when updating selinux-policy
Transaction errors when updating selinux-policy
Status: CLOSED DUPLICATE of bug 480968
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-18 11:35 EST by Jesse Keating
Modified: 2013-01-09 22:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-02 14:28:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2009-01-18 11:35:20 EST
Updating       : selinux-policy                                                                                                 232/508 
Traceback (most recent call last):
  File "/usr/bin/sepolgen-ifgen", line 32, in <module>
    import sepolgen.refparser as refparser
ImportError: No module named sepolgen.refparser

Perhaps a missing Requires or Requires(post) ?
Comment 1 Daniel Walsh 2009-01-19 15:23:40 EST
Strange they should be in the same package

# rpm -qf /usr/lib64/python2.6/site-packages/sepolgen/refparser.py
policycoreutils-python-2.0.61-2.fc11.x86_64

# rpm -qf /usr/bin/sepolgen-ifgen 
policycoreutils-python-2.0.61-2.fc11.x86_64
Comment 2 Daniel Walsh 2009-01-19 15:24:02 EST
Is this during an install?
Comment 3 Jesse Keating 2009-01-19 17:24:05 EST
I do believe this was an upgrade.  That is indeed quite strange.
Comment 4 Daniel Walsh 2009-01-19 17:38:27 EST
Well those files used to be in policycoreutils and are moving to policycoreutils-python, so we can eliminate python from the minimal install.  

If those files are in the mist of a transaction I wonder if this could happen.

The code is supposed to check for the existance of   /usr/bin/sepolgen-ifgen

[ -x /usr/bin/sepolgen-ifgen ] && /usr/bin/sepolgen-ifgen 


But this file should not be there if the other python code is not.
Comment 5 Jesse Keating 2009-01-20 20:00:13 EST
That is a weird one.  I'm going to drop if off of the Alpha tracker, but leave the bug open.  Will try to reproduce at some point.
Comment 6 Daniel Walsh 2009-02-02 14:28:00 EST

*** This bug has been marked as a duplicate of bug 480968 ***

Note You need to log in before you can comment on or make changes to this bug.