Bug 480615 - audacity update fails to install.
audacity update fails to install.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: audacity (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 480617
  Show dependency treegraph
 
Reported: 2009-01-19 08:36 EST by David Woodhouse
Modified: 2009-01-21 16:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 480617 (view as bug list)
Environment:
Last Closed: 2009-01-21 16:27:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2009-01-19 08:36:23 EST
Looks like audacity needs rebuilding for F-9...

audacity-1.3.5-0.7.beta.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: libvamp-hostsdk.so.2.0.0 is needed by package audacity-1.3.5-0.7.beta.fc9.i386 (installed)
Error: Missing Dependency: libvamp-hostsdk.so.2.0.0 is needed by package audacity-1.3.5-0.7.beta.fc9.i386 (installed)

Why did libvamp-hostsdk get rebuilt and pushed without pushing the dependent packages?
Comment 1 David Woodhouse 2009-01-19 08:37:23 EST
Perhaps bohdi should warn loudly before pushing packages which would have (or cause) unresolvable dependencies?
Comment 2 Michael Schwendt 2009-01-19 09:32:00 EST
I've prepared a fresh build yesterday:
https://admin.fedoraproject.org/updates/audacity-1.3.5-0.8.beta.fc9

> Why did libvamp-hostsdk get rebuilt and pushed without
> pushing the dependent packages?

Because some packagers skip the extra work that is needed to check mass-updates [for multiple dist releases] for compatibility:
https://admin.fedoraproject.org/updates/F9/FEDORA-2008-11288
https://admin.fedoraproject.org/updates/F9/FEDORA-2008-11914
Comment 3 Fedora Update System 2009-01-21 16:27:09 EST
audacity-1.3.5-0.8.beta.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.