Bug 480638 - Anaconda hangs right after keyboard selection. (HP DL585G5)
Anaconda hangs right after keyboard selection. (HP DL585G5)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-19 10:59 EST by Gilboa Davara
Modified: 2009-09-10 07:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 07:32:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilboa Davara 2009-01-19 10:59:09 EST
Description of problem:
Trying to install Fedora 10/x86_64 on an HP DL585G5 w/ 4 x AMD Opteron 8354.
The installer boots, Anaconda starts and displays the CD-check and the keyboard selection dialog.
Once I finish selecting the keyboard (English / US), Anaconda hangs. (Broken cciss detection?)
AFAICS, it's not a kernel problem - the text consoles are active and responsive and there's nothing in the system/kernel logs.
P.S. Fedora 9's anaconda works just fine.

How reproducible:
Always.

Additional info:

Configuration:
HP DL585G5.
4 x AMD Opteron 8356.
36GB RAM.
8 x 146GB 10K/SAS in RAID5.
1 x PCI-E quad port GbE NIC. (e1000e)
2 x PCI-E single port 10GbE NIC. (ixgbe)

$ lspci
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a4)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev b1)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a4)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev a3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Link Control
00:19.0 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:19.1 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Address Map
00:19.2 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] DRAM Controller
00:19.3 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Miscellaneous Control
00:19.4 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Link Control
00:1a.0 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:1a.1 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Address Map
00:1a.2 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] DRAM Controller
00:1a.3 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Miscellaneous Control
00:1a.4 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Link Control
00:1b.0 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:1b.1 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Address Map
00:1b.2 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] DRAM Controller
00:1b.3 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Miscellaneous Control
00:1b.4 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Link Control
01:03.0 VGA compatible controller: ATI Technologies Inc ES1000 (rev 02)
01:04.0 System peripheral: Compaq Computer Corporation Integrated Lights Out Controller (rev 03)
01:04.2 System peripheral: Compaq Computer Corporation Integrated Lights Out  Processor (rev 03)
01:04.4 USB Controller: Hewlett-Packard Company Proliant iLO2 virtual USB controller
01:04.6 IPMI SMIC interface: Hewlett-Packard Company Proliant iLO2 virtual UART
02:00.0 Ethernet controller: Intel Corporation 82598EB 10 Gigabit AF Network Connection (rev 01)
05:00.0 Ethernet controller: Intel Corporation 82598EB 10 Gigabit AF Network Connection (rev 01)
08:00.0 RAID bus controller: Hewlett-Packard Company Smart Array Controller (rev 04)
40:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a4)
40:01.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev b1)
40:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
40:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
40:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
40:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
40:10.0 PCI bridge: Advanced Micro Devices [AMD] AMD-8132 PCI-X Bridge (rev 12)
40:10.1 PIC: Advanced Micro Devices [AMD] AMD-8132 PCI-X IOAPIC (rev 12)
40:11.0 PCI bridge: Advanced Micro Devices [AMD] AMD-8132 PCI-X Bridge (rev 12)
40:11.1 PIC: Advanced Micro Devices [AMD] AMD-8132 PCI-X IOAPIC (rev 12)
41:01.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5706 Gigabit Ethernet (rev 02)
41:02.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5706 Gigabit Ethernet (rev 02)
49:00.0 PCI bridge: Integrated Device Technology, Inc. Unknown device 8018 (rev 04)
4a:00.0 PCI bridge: Integrated Device Technology, Inc. Unknown device 8018 (rev 04)
4a:01.0 PCI bridge: Integrated Device Technology, Inc. Unknown device 8018 (rev 04)
4b:00.0 Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet Controller (rev 06)
4b:00.1 Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet Controller (rev 06)
4c:00.0 Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet Controller (rev 06)
4c:00.1 Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet Controller (rev 06)

- Gilboa
Comment 1 Chris Lumens 2009-01-21 09:35:43 EST
Right after keyboard selection is disk probing, so it's entirely possible that this is a CCISS-related issue.  We use a thin wrapper around hal and dbus to do this probing, and I do believe there have been hal+CCISS problems in the past.  Let's try reassigning.
Comment 2 Phil 2009-03-19 17:38:23 EDT
As this issue involves hardware raid and hangs just after keyboard/language selection, just like the nVidia fake raid bug, should this issue be added to the DMRAID master bug #489148??

Are you able to try an installation with the latest Fedora 11 release and updated .img?

1. download and burn latest F11 prerelease
2. boot from media
3. at the selection menu of Install/Upgrade, Boot from local disc etc. press tab to add commands to the end of the "install/upgrade" kernel line
4. add "update=<url below>" without quotes

http://jgranado.fedorapeople.org/storage/testing/19-03-2009-1452-x86_64.img
http://jgranado.fedorapeople.org/storage/testing/19-03-2009-1452-i586.img

5. go through install process

after checking the install media NetworkManager should prompt you to start your NIC so it can download this latest patch.  after that hopefully you should be able to get past language selection and on the partition modification.

If you have any success or issues with this can you please add your experience to the master bug?
https://bugzilla.redhat.com/show_bug.cgi?id=489148


cheers,

Phil
Comment 3 Gilboa Davara 2009-03-20 01:56:40 EDT
Phil,

It's not a fake RAID - it's a real, honest to God, SAS RAID. (HP Smart Array P400).

As for the F11 prerelease - can I somehow download the latest PXEIMAGE (initrd.img & vmlinuz), from somewhere? (I don't have physical access to the machine until mid-next week, but I can remotely manage / install it from home...)

- Gilboa
Comment 4 Hans de Goede 2009-03-20 07:44:56 EDT
(In reply to comment #3)
> Phil,
> 
> It's not a fake RAID - it's a real, honest to God, SAS RAID. (HP Smart Array
> P400).
> 

Ack.

> As for the F11 prerelease - can I somehow download the latest PXEIMAGE
> (initrd.img & vmlinuz), from somewhere? (I don't have physical access to the
> machine until mid-next week, but I can remotely manage / install it from
> home...)
> 

You can find them in the development/i386/os/images/pxeboot on any Fedora mirror.
Comment 5 Gilboa Davara 2009-04-01 15:03:28 EDT
Anaconda dies a horrible death while trying to install F11/B. [1]
Never the less, it seems the F11 does managed to detect the RAID before committing suicide, so I guess it's progress :)

- Gilboa
[1] https://bugzilla.redhat.com/show_bug.cgi?id=493350
Comment 6 Scott Glaser 2009-09-09 08:43:24 EDT
Have you tried with the latest hal package in Fedora 10, Fedora 11 or tried Rawhide? In either case, can you let us know whether the issue is still happening, and give the current version of the HAL packages you're using?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Gilboa Davara 2009-09-10 07:20:16 EDT
I just installed F11 on this machine. No problems.

Bug can be safely closed.

Thanks!
- Gilboa
Comment 8 Scott Glaser 2009-09-10 07:32:46 EDT
Based on the information in comment 7 I am closing this bug, should you
experience these symptoms again please file a new bug report against the
applicable component.  Thanks for the input.


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.