Bug 480731 - battery test failed in rhel4 i386 plat (using hts-5.3-12)
battery test failed in rhel4 i386 plat (using hts-5.3-12)
Status: CLOSED WONTFIX
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.3
All Linux
low Severity medium
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 01:46 EST by Vivian Bian
Modified: 2014-03-25 20:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-27 16:49:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
result displayed in the terminal (147.54 KB, image/png)
2009-01-20 01:46 EST, Vivian Bian
no flags Details
the result.xml file in the /var/hts (30.51 KB, text/xml)
2009-01-20 01:47 EST, Vivian Bian
no flags Details
the en_US locale failures in the terminal (158.71 KB, image/png)
2009-01-20 21:43 EST, Vivian Bian
no flags Details
en_US locale /var/hts/result.xml (30.51 KB, text/xml)
2009-01-20 21:45 EST, Vivian Bian
no flags Details
/var/log/hts/runs/1/battery/output.log in en_US locale (128 bytes, text/x-log)
2009-01-20 21:46 EST, Vivian Bian
no flags Details

  None (edit)
Description Vivian Bian 2009-01-20 01:46:03 EST
Created attachment 329429 [details]
result displayed in the terminal

Description of problem:
manually add the battery test suite to the hts plan,and excute it,but the test could not excute successfully.

Version-Release number of selected component (if applicable):
hts-5.3-12.EL4.i386
kernel-2.6.9-78.28.EL i386
IBM T43 laptop
Battery type: 6 Cell Lithium-Ion

How reproducible:
Always

Steps to Reproduce:
1.# hts plan --add --test=battery --device=0
2.# hts run -t battery

  
Actual results:
the charge and uncharge functions are not checked,but the test suite executed failed

Expected results:
the charge and uncharge of the battery will be checked during executing the test suite

Additional info:
Comment 1 Vivian Bian 2009-01-20 01:47:50 EST
Created attachment 329430 [details]
the result.xml file in the /var/hts
Comment 2 Greg Nichols 2009-01-20 08:41:37 EST
What locale is this system set to?
Comment 3 Vivian Bian 2009-01-20 20:21:23 EST
the locale for the system is set to zh_CN
Comment 4 Greg Nichols 2009-01-20 21:02:02 EST
For certification, systems must be set to en_US.   This is quite likely the cause of the traceback, as HTS parses the system log.   Closing as WONTFIX, as support for zh_CN is outside HTS's requirements.
Comment 5 Vivian Bian 2009-01-20 21:43:02 EST
Sorry,but the bug could not be closed ,for the en_US locale could not run the battery test successfully.

# locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
Comment 6 Vivian Bian 2009-01-20 21:43:55 EST
Created attachment 329527 [details]
the en_US locale failures in the terminal
Comment 7 Vivian Bian 2009-01-20 21:45:19 EST
Created attachment 329528 [details]
en_US locale /var/hts/result.xml
Comment 8 Vivian Bian 2009-01-20 21:46:46 EST
Created attachment 329529 [details]
/var/log/hts/runs/1/battery/output.log  in en_US locale
Comment 9 Vivian Bian 2009-01-20 21:51:59 EST
the locale for the system is set to zh_CN
Comment 10 Vivian Bian 2009-01-20 21:52:42 EST
the comment #9 is a mistake submit
Comment 11 Greg Nichols 2009-01-20 21:59:27 EST
How was the locale changed from zh_CN to en_US?
Comment 12 Vivian Bian 2009-01-20 22:01:45 EST
changed from the Applications->System Settings->Language
Comment 13 Greg Nichols 2009-01-21 08:50:41 EST
I suspect the problem is that messages were logged in the system log when it was set to zh_CH that are still causing the traceback.  Could you make sure the system logs are cleared and re-run the test?

Note You need to log in before you can comment on or make changes to this bug.