Bug 480732 - no socket test loaded and can't add socket test in manual
no socket test loaded and can't add socket test in manual
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.3
All Linux
low Severity medium
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 02:06 EST by Vivian Bian
Modified: 2014-03-25 20:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 17:59:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the result.xml file in the /var/hts (30.51 KB, text/xml)
2009-01-20 02:06 EST, Vivian Bian
no flags Details
the result displayed in the terminal (95.41 KB, image/png)
2009-01-20 02:07 EST, Vivian Bian
no flags Details
/var/hts/results.xml for hts-5.3-15 (141.22 KB, text/xml)
2009-01-23 01:03 EST, Yan Tian
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0047 normal SHIPPED_LIVE hts bug fix update 2009-01-27 17:57:30 EST

  None (edit)
Description Vivian Bian 2009-01-20 02:06:29 EST
Created attachment 329434 [details]
the result.xml file in the /var/hts

Description of problem:
try to add the test suite socket to the test plan manually,but was told no test-suite ['socket'].check the suite in /usr/share/hts/test directory,the socket suite is installed there.

Version-Release number of selected component (if applicable):
hts-5.3-12.EL4.i386
kernel-2.6.9-78.28.EL
IBM T43 laptop

How reproducible:
Always

Steps to Reproduce:
1.# hts plan --add --test=socket
2.# ls /usr/share/hts/tests/

  
Actual results:
the socket test suite could not be added although it is existing in the /usr/share/hts/tests

Expected results:
the socket test suite could be added into the plan successfully

Additional info:
Comment 1 Vivian Bian 2009-01-20 02:07:19 EST
Created attachment 329435 [details]
the result displayed in the terminal
Comment 2 Greg Nichols 2009-01-20 08:37:25 EST
Test log:
Running ./battery.py:
Error: could not find HAL device for battery and AC Adapter
...finished running ./battery.py, exit code=1

The problem is that the battery test relies on HAL.   The test needs
to use kudzu on RHEL4
Comment 3 Greg Nichols 2009-01-20 08:38:47 EST
In addition, this bug prevents HTS from planning the battery test on RHEL4
Comment 4 Rob Landry 2009-01-20 12:40:55 EST
I've duplicated this with hts-5.3-9, and 5.3-14 and verified that 5.2-20 does not have this issue.
Comment 5 YangKun 2009-01-20 19:59:33 EST
does this mean the battery test is not required for RHEL4-laptop certs ?
Comment 6 Greg Nichols 2009-01-21 21:13:03 EST
The problem is that the socket test conflicts with a "socket" python library, so the test is never planned.   The best fix is to rename the test as "pccard", which means changing the directory name, and file names within the test directory.
Comment 7 Yan Tian 2009-01-22 00:25:04 EST
Reproduced this bug in hts-5.3-14 with T60 laptop on RHEL5.3 Server i386 system.
Comment 10 Yan Tian 2009-01-23 01:02:46 EST
Verified this bug was not fixed in hts-5.3-15.el5 with T60 laptop. Reopened this bug. Attached /var/hts/result.xml file.

[root@dhcp-66-70-61 Desktop]# rpm -q hts
hts-5.3-15.el5
[root@dhcp-66-70-61 Desktop]# hts plan
/var/hts
OS Version: Red Hat Enterprise Linux Server release 5.3 Beta (Tikanga)
Kernel RPM: kernel-2.6.18-128.el5
HTS version 5.3, release 15
Hardware: LENOVO unknown 2007MT1
OS: Tikanga 5.3
saved configuration to /var/hts/results.xml
Created a new plan with 19 tests on 104 devices
saved test plan to /var/hts/results.xml
[root@dhcp-66-70-61 Desktop]# hts print plan
/var/hts

Test Plan:
----------------------------------------------------------------
suspend               acpi_BAT0                            
expresscard            pnp_ATM1200                          
dvd        hda        storage_model_HL_DT_STCD_RW/DVD_DRIVE_GCC_4247N 
cdrom      hda        storage_model_HL_DT_STCD_RW/DVD_DRIVE_GCC_4247N 
battery               acpi_BAT0                            
usb                   pnp_ATM1200                          
lid                   acpi_LID                             
audio                 pci_8086_27d8_alsa_playback_1        
network    wlan0      net_00_1b_77_02_f5_c2                
network    eth0       net_00_15_58_86_31_5e                
memory                                                     
video                 pci_1002_7149                        
core                                                       
cpuscaling 0          acpi_CPU0                            
cpuscaling 1          acpi_CPU1                            
pccard                pci_104c_ac56                        
profiler                                                   
storage    sda        storage_serial_SATA_FUJITSU_MHV2120_NW9ST7428K6N 
info                                                       
[root@dhcp-66-70-61 Desktop]# hts plan -a -t socket
/var/hts
loaded results /var/hts/results.xml
OS Version: Red Hat Enterprise Linux Server release 5.3 Beta (Tikanga)
Kernel RPM: kernel-2.6.18-128.el5
HTS version 5.3, release 15
OS Version: Red Hat Enterprise Linux Server release 5.3 Beta (Tikanga)
Kernel RPM: kernel-2.6.18-128.el5
HTS version 5.3, release 15
No such test ['socket']
saved test plan to /var/hts/results.xml
Comment 11 Yan Tian 2009-01-23 01:03:30 EST
Created attachment 329778 [details]
/var/hts/results.xml for hts-5.3-15
Comment 12 Greg Nichols 2009-01-23 08:58:08 EST
The socket test was renamed to "pccard", which shows up in the test plan in your attachments.   So this is VERIFIED.
Comment 14 errata-xmlrpc 2009-01-27 17:59:02 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0047.html

Note You need to log in before you can comment on or make changes to this bug.