Bug 480777 - RHEL4.8 kernel hangs during boot, possible APIC and PM timer calibration issue
RHEL4.8 kernel hangs during boot, possible APIC and PM timer calibration issue
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.8
All Linux
low Severity medium
: rc
: ---
Assigned To: Prarit Bhargava
Mike Gahagan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 09:25 EST by Vivek Goyal
Modified: 2009-02-17 07:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 07:06:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vivek Goyal 2009-01-20 09:25:13 EST
Description of problem:

79.EL kernel hanged on two machines during boot. Following was last message on the console.

ACPI: System reset via FADT Reset Register is supported
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 pin1=2 pin2=-1
APIC calibration not consistent with PM Timer: 4393459ms instead of 100ms
APIC delta adjusted to PM-Timer: 139 (1662345)

Noticed on two systems so far.

http://rhts.redhat.com/cgi-bin/rhts/test_list.cgi?test_filter=/distribution/install&result=Fail&rwhiteboard=kernel%202.6.9-79.EL%20hugemem&arch=i386&jobids=42262
http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=5997710

Version-Release number of selected component (if applicable):
79.EL

How reproducible:
Noticed twice. Jeff says it is not reproducible 100% of time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Vivek Goyal 2009-01-20 09:29:28 EST
error messages seems to be coming from prarit's recent patch.

commit 41ec0677ef6c42134dab423a4027b8518325ad59
Author: Prarit Bhargava <prarit@redhat.com>
Date:   Tue Aug 26 09:55:03 2008 -0400

    identify pm timer calibration issues during boot
Comment 3 Prarit Bhargava 2009-02-17 07:06:30 EST
Patch was withdrawn from RHEL4.8.

CLOSED as NOTABUG.

P.

Note You need to log in before you can comment on or make changes to this bug.