Bug 480795 - groupadd: GID 87 is not unique
groupadd: GID 87 is not unique
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 480971 481588 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 11:30 EST by Mamoru TASAKA
Modified: 2009-01-29 06:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 06:51:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2009-01-20 11:30:41 EST
Description of problem:
With udev-136-2.fc11.i386, udev %post scriptlet contains:
getent group dialout >/dev/null || /usr/sbin/groupadd -g 87 dialout || :

However, on my system:
# ( LANG=C ; getent group dialout >/dev/null || /usr/sbin/groupadd -g 87 dialout || : )
groupadd: GID 87 is not unique

Then:
$ grep :87 /etc/group
polkituser:x:87:
and rpm -q --scripts PolicyKit shows
preinstall scriptlet (using /bin/sh):
/usr/sbin/useradd -c 'PolicyKit' -u 87 \
        -s /sbin/nologin -r -d '/' polkituser 2> /dev/null || :

This will create PolicyKit user with uid 87 and gid 87
(by Fedora shadow-utils)


Version-Release number of selected component (if applicable):
udev-136-2.fc11.i386
PolicyKit-0.9-4.fc11.i386

How reproducible:
100%

Steps to Reproduce:
1. # yum -y upgrade udev
2.
3.
  
Actual results:
See above
Comment 1 Harald Hoyer 2009-01-22 04:25:46 EST
*** Bug 480971 has been marked as a duplicate of this bug. ***
Comment 2 Harald Hoyer 2009-01-22 04:45:26 EST
well, polkituser isn't supposed to have this gid .. see bug #480776
Comment 3 Harald Hoyer 2009-01-26 15:54:08 EST
*** Bug 481588 has been marked as a duplicate of this bug. ***
Comment 4 David Zeuthen 2009-01-28 13:02:31 EST
Am afraid that gid 87 is already taken and there was some miscommunication when it was "allocated". But PolicyKit is using that gid for a number of things so we can't really change it.
Comment 5 Harald Hoyer 2009-01-29 06:51:30 EST
dialout has gid 18 now with udev-137-1

Note You need to log in before you can comment on or make changes to this bug.