Bug 480799 - typo in /etc/init.d/halt
typo in /etc/init.d/halt
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
: 480882 494861 495081 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 11:58 EST by Tom London
Modified: 2014-03-16 23:17 EDT (History)
5 users (show)

See Also:
Fixed In Version: 8.86.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 12:51:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2009-01-20 11:58:13 EST
Description of problem:
reboot and/or halt fails with error on line 178....  missing ']'

--- halt.old	2009-01-20 08:52:41.000000000 -0800
+++ halt	2009-01-20 08:52:53.000000000 -0800
@@ -175,6 +175,6 @@
 [ -n "$kexec_command" ] && $kexec_command -e -x >& /dev/null
 
 HALTARGS="-d"
-[ "$INIT_HALT" != "HALT"] && HALTARGS="$HALTARGS -p"
+[ "$INIT_HALT" != "HALT" ] && HALTARGS="$HALTARGS -p"
 
 exec $command $HALTARGS


Version-Release number of selected component (if applicable):
initscripts-8.87-1.x86_64

How reproducible:
yup.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2009-01-20 12:51:11 EST
Fixed in git.
Comment 2 Bill Nottingham 2009-01-20 22:27:21 EST
*** Bug 480882 has been marked as a duplicate of this bug. ***
Comment 3 Mary Ellen Foster 2009-04-09 05:20:49 EDT
*** Bug 494861 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2009-04-09 13:08:30 EDT
*** Bug 495081 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2009-04-22 16:22:26 EDT
initscripts-8.86.3-1 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.