Bug 480874 - no longer notices network changes automatically
no longer notices network changes automatically
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 20:08 EST by Bill Nottingham
Modified: 2014-03-16 23:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-10 18:58:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2009-01-20 20:08:06 EST
Description of problem:

When I bring up or bring down the VPN with NetworkManager, Firefox no longer automatically notices and adjusts its DNS search accordingly. I either have to wait ~30-40 seconds for a request to time out (at which point it switches), or manually toggle offline/online.

In 3.0, this worked fine.

Version-Release number of selected component (if applicable):

firefox-3.1-0.4.beta2.fc11.x86_64
Comment 1 Matěj Cepl 2009-01-27 20:31:41 EST
DNS search is not something which Firefox would deal with -- why this isn't NM bug? And of course, I don't think Firefox cares at all about VPNs -- it checks from NM only whether the network connection is up or down, but which connection doesn't concern it, AFAIK.

Putting Dan on CC of this bug, but I think that this should belong to NM component.
Comment 2 Bill Nottingham 2009-01-28 10:44:06 EST
I am assuming that it's a firefox bug, in that it used to work, firefox was updated from 3.0.x to 3.1beta, and now it does not work.
Comment 3 Matěj Cepl 2009-01-28 13:19:32 EST
can I get here an output of nm-tool when the network connection is up and Firefox doesn't see it, please?
Comment 4 Dan Williams 2009-01-28 13:30:13 EST
Matej: NM changes /etc/resolv.conf when you connect to the VPN.  The glibc resolver does not notice changes to /etc/resolv.conf automatically, applications must call __res_init() manually.  FF *used* to internally call __res_init() before any DNS lookup to ensure that it had the right DNS servers if /etc/resolv.conf had changed since it started up.  Perhaps that's no longer the case.

Either apps need to handle /etc/resolv.conf changing themselves, or the user needs to run 'nscd', or glibc needs to detect changes to /etc/resolv.conf.
Comment 6 Matěj Cepl 2009-01-28 15:15:13 EST
I don't think I can triage anything here, and hopefully the situation is clear to Christopher. Enjoy this!
Comment 7 Christopher Aillon 2009-02-07 17:51:13 EST
Is this resolved with xulrunner-1.9.1-0.7.beta2.fc11 ?
Comment 8 Bill Nottingham 2009-02-10 18:58:40 EST
Appears to be.

Note You need to log in before you can comment on or make changes to this bug.