Bug 480875 - PulseAudio not working, possibly not loading after uninstall-reinstall
PulseAudio not working, possibly not loading after uninstall-reinstall
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
10
i386 Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 20:08 EST by Victoria Earl
Modified: 2009-01-21 11:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 11:42:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Victoria Earl 2009-01-20 20:08:49 EST
Description of problem:
After uninstalling, then reinstalling the RPM through yum, sound is off across the board.  Alsamixer shows the sounds IEC985 and IEC985 D as on, but with no volume nor adjustment possible.  Suspected that pulseaudio is not running.

Version-Release number of selected component (if applicable):
0.9.13

How reproducible:
Unsure of how reproducible this is; sound was not tested beforehand so I do not know if uninstall/reinstall actually broke the app or if it was never working to begin with.

Steps to Reproduce:
1. bash (using Terminal): yum remove pulseaudio
2. yum install pulseaudio
3.
  
Actual results:
No sound from any components, including browser, .mp3, and system sounds.

Expected results:
Sound.

Additional info:
Output of pulseaudio command when ran as root:
W: main.c: This program is not intended to be run as root (unless --system is specified).
E: alsa-util.c: Error opening PCM device hw:0: Device or resource busy
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_8086_27d8_sound_card_0_alsa_playback_0 tsched=1"): initialization failed.
(program freezes here)

Verbose output of pulseaudio command as user:
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: main.c: PolicyKit refuses acquire-high-priority privilege.
N: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us privileges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
W: main.c: High-priority scheduling enabled in configuration but not allowed by policy.
W: core-util.c: setpriority(): Permission denied
I: main.c: This is PulseAudio 0.9.13
I: main.c: Page size is 4096 bytes
I: main.c: Machine ID is 2a47539d4beb3f012f184a3f4971f42e.
I: main.c: Using runtime directory /home/kitsuta/.pulse/2a47539d4beb3f012f184a3f4971f42e:runtime.
I: main.c: Using state directory /home/kitsuta/.pulse.
I: main.c: Running in system mode: no
E: pid.c: Daemon already running.
E: main.c: pa_pid_file_create() failed.
Comment 1 Victoria Earl 2009-01-20 21:36:22 EST
As an aside, I did log out and back in after uninstalling/installing pulseaudio.

Relavent pastebins:
http://fpaste.org/paste/1850
http://fpaste.org/paste/1851
http://fpaste.org/paste/1852
http://fpaste.org/paste/1853
http://fpaste.org/paste/1854
http://fpaste.org/paste/1855

cat /dev/urandom > /dev/dsp
produces white noise
Comment 2 Victoria Earl 2009-01-21 00:09:50 EST
Works when rebooting into GNOME.
Comment 3 Lennart Poettering 2009-01-21 11:42:27 EST
The PA output you pasted shows that some other application is blocking access to the sound device and hence PA cannot get access to it. Use "fuser -v /dev/dsp* dev/snd/*". You subsequent dumps show that firefox (most likely flash) are the culprits.

Don't run PA as root!

The second dump shows that PA is already running.

This is not really a PA issue, hence closing.

Note You need to log in before you can comment on or make changes to this bug.