Bug 480882 - initscripts - missing blank prevents powering off on shutdown
initscripts - missing blank prevents powering off on shutdown
Status: CLOSED DUPLICATE of bug 480799
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 22:12 EST by Michal Jaegermann
Modified: 2014-03-16 23:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 22:27:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2009-01-20 22:12:54 EST
Description of problem:

/etc/rc.d/init.d/halt is missing blank; like that:

--- halt~       2009-01-19 15:07:14.000000000 -0700
+++ halt        2009-01-20 20:00:55.000000000 -0700
@@ -175,6 +175,6 @@ fi
 [ -n "$kexec_command" ] && $kexec_command -e -x >& /dev/null
 
 HALTARGS="-d"
-[ "$INIT_HALT" != "HALT"] && HALTARGS="$HALTARGS -p"
+[ "$INIT_HALT" != "HALT" ] && HALTARGS="$HALTARGS -p"
 
 exec $command $HALTARGS

The net result is that the script chokes with "missing ]" and a machine refuses to power down on "Shutdown".

Version-Release number of selected component (if applicable):
initscripts-8.87-1.x86_64

How reproducible:
always
Comment 1 Bill Nottingham 2009-01-20 22:27:21 EST

*** This bug has been marked as a duplicate of bug 480799 ***

Note You need to log in before you can comment on or make changes to this bug.