Bug 480905 - Satellite Proxy installer for 5.3
Satellite Proxy installer for 5.3
Status: CLOSED DUPLICATE of bug 480893
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Devel
All Linux
low Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Red Hat Network Quality Assurance
:
Depends On: 480894
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 04:55 EST by Miroslav Suchý
Modified: 2013-01-10 04:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 480894
Environment:
Last Closed: 2009-07-23 15:48:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2009-01-21 04:55:06 EST
+++ This bug was initially created as a clone of Bug #480894 +++

We need to add RHN Proxy 5.3 to the RHN Satellite WebUI.  There are two parts to this:

First, please copy the 5.2 installer to 5.3.

Second, modify web/modules/rhn/RHN/DB/Channel.pm so it is aware of the 5.3 proxy channels (for all four architectures and for rhel4 and rhel5):

               '5.3' => ['redhat-rhn-proxy-5.3-as-i386-4',
                         'redhat-rhn-proxy-5.3-as-x86_64-4',
                         'redhat-rhn-proxy-5.3-as-s390-4',
                         'redhat-rhn-proxy-5.3-as-s390x-4',
                         'redhat-rhn-proxy-5.3-server-i386-5',
                         'redhat-rhn-proxy-5.3-server-x86_64-5',
                         'redhat-rhn-proxy-5.3-server-s390x-5',
                        ],

This is around line 354.  While you're there, can you remove the line:

 	                 'redhat-rhn-proxy-5.2-server-s390-5',

This should have never been there for 5.2.

--- Additional comment from msuchy@redhat.com on 2009-01-21 04:32:13 EDT ---

> please copy the 5.2 installer to 5.3.
Already done yesterday in commit: fa7a720e337277a299a70c94f7f39961e139d777

> Second, modify web/modules/rhn/RHN/DB/Channel.pm so it is aware of the 5.3
Commited as b01b6783815810f88ee9bb57828b9be3a6aa280e

> While you're there, can you remove the line: 'redhat-rhn-proxy-5.2-server-s390-5',
I could not find it in source any more. Ignoring.
Comment 1 Miroslav Suchý 2009-01-21 04:58:13 EST
You may want to take up 5.3 web ui dir from:
 https://fedorahosted.org/spacewalk/browser/web/html/applications/rhn-proxy/5.3
Note that it is not just copy of previous 5.2 and it contains some modification (which did not pass neither QA nor basic validation at this momment).
So you may want to wait before 480894 is validated.
Comment 2 Stephen Herr 2009-07-23 15:48:29 EDT

*** This bug has been marked as a duplicate of bug 480893 ***

Note You need to log in before you can comment on or make changes to this bug.