Bug 480909 - Two question windows when installing from the web
Two question windows when installing from the web
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 05:20 EST by Michael Monreal
Modified: 2009-01-23 08:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 08:41:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (49.99 KB, image/png)
2009-01-21 05:22 EST, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2009-01-21 05:20:41 EST
I found it very handy to be able to install the repo definitions of rpmfusion and livna using a simple click on a link on their web pages.

However

- doing so pops up a window asking if I want to install the package. This is fine
- after pressing install, there's another window asking if I want to copy the package. Huh? IMHO pressing install in the first window should also answer this question. This would make the process much smoother.
Comment 1 Michael Monreal 2009-01-21 05:22:44 EST
Created attachment 329578 [details]
Screenshot
Comment 2 Richard Hughes 2009-01-21 07:05:14 EST
What version gnome-packagekit? I thought we fixed this problem months ago?

These are the related commits:

commit 8a0937db1541fe6fbc5469ca9b1c54c2fc564048
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Nov 5 08:56:15 2008 +0000

    bugfix: add a GConf key /apps/gnome-packagekit/show_copy_confirm to allow
    distributions to choose whether to show the copy from FUSE dialog. Also show
    a copy progress bar with an aync handler. Affects rh#469963

commit 838241d093a7be7600d05d35d02b6e6050904b28
Author: Richard Hughes <richard@hughsie.com>
Date:   Fri Oct 31 17:25:56 2008 +0000

    bugfix: fix the interaction when installing local files by only showing the copy dialog for non-native paths. Also add a confirm dialog when the files were installed correctly, and also make sure the dialog is shown for the untrusted 2nd pass of the installation. Fixes rh#469275
Comment 3 Richard Hughes 2009-01-21 07:05:42 EST
oops, checked wrong checkbox.
Comment 4 Michael Monreal 2009-01-21 08:34:39 EST
Sorry I think you are right. I thought I had installed all updates already (there was not updates available icon in the tray anymore) but it looks like I was not up-to-date with PK. I removed the livna repo rpm after really installing all updates and tried again, this time I only got one dialog. Thanks!
Comment 5 Richard Hughes 2009-01-21 08:41:17 EST
Cool, thanks for verifying.
Comment 6 Michael Monreal 2009-01-22 03:58:22 EST
Update: I did a second installation with Rawhide and installation from the web does not really work there. It may be related to Rawhide though so I don't file a new bug for this just yet. What happens:

---
An internal system error has occured

A problem thatwe were not expecting has occurred.
Please report this bug in your distribution bugtracker with the error description.

=> No Package Matching rpmfusion-nonfree-release
---

It downloads the package but fails to install. I can install it with rpm -i just fine, so the package is not broken or anything.
Comment 7 Richard Hughes 2009-01-23 08:01:09 EST
Yes, a bug in the yum backend in 0.4.0. You want these new packages: http://koji.fedoraproject.org/koji/taskinfo?taskID=1075915

Note You need to log in before you can comment on or make changes to this bug.