Bug 480917 - gpk-application uses fixed-size boxes breaking window layout for packages with long descriptions
gpk-application uses fixed-size boxes breaking window layout for packages wit...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
10
All Linux
urgent Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 480981 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 06:36 EST by Lev Shamardin
Modified: 2009-01-21 13:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 07:00:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Broken window - standard size (90.49 KB, image/png)
2009-01-21 06:37 EST, Lev Shamardin
no flags Details
Broken window - maximized (154.73 KB, image/png)
2009-01-21 06:37 EST, Lev Shamardin
no flags Details

  None (edit)
Description Lev Shamardin 2009-01-21 06:36:12 EST
Description of problem:
text box for package description resides on a fixed-size pane, which is a problem in case of a long package description.

Version-Release number of selected component (if applicable):
gnome-packagekit-0.3.12-1.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. Login to a gnome desktop, select System->Administration->Add/Remove software.
2. Type "enlightenment" in the search box.
  
Actual results:
A window with a broken layout, which is barely useful even if maximized with 1440x900 screen resolution.

Expected results:
Package description box should be resizable.

Additional info:
I will attach screenshots of the problem to this bug.
Comment 1 Lev Shamardin 2009-01-21 06:37:14 EST
Created attachment 329589 [details]
Broken window - standard size
Comment 2 Lev Shamardin 2009-01-21 06:37:47 EST
Created attachment 329590 [details]
Broken window - maximized
Comment 3 Richard Hughes 2009-01-21 07:00:57 EST
Already fixed -- I'll update F10 once F11 alpha is out of the door:

commit cf168c8a019b2371346d4f96ab509a23b0821c07
Author: Richard Hughes <richard@hughsie.com>
Date:   Mon Jan 19 09:22:27 2009 +0000

    bugfix: use scrollbars in the description, and set the hbox to a fixed size to avoid flicker. Based on a patch from Jens Knutson, many thanks. Fixes fd#19633

:100644 100644 2bab3e5... 18702bb... M  data/gpk-application.glade
:100644 100644 8f16a7c... 8aa9cfe... M  src/gpk-application.c
Comment 4 Richard Hughes 2009-01-21 13:36:30 EST
*** Bug 480981 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.