Bug 480935 - Dragging icon over breadcrumbs results in persistent black rectangle
Dragging icon over breadcrumbs results in persistent black rectangle
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 08:41 EST by James Ettle
Modified: 2018-04-11 14:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-23 05:43:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (48.65 KB, text/plain)
2009-07-24 03:14 EDT, James Ettle
no flags Details
a dmesg (43.48 KB, text/plain)
2009-07-24 03:15 EDT, James Ettle
no flags Details
Screenshot of the problem (42.10 KB, image/png)
2009-07-24 03:17 EDT, James Ettle
no flags Details

  None (edit)
Description James Ettle 2009-01-21 08:41:32 EST
Description of problem:
Dragging an icon onto one of the breadcrumb buttons (that display the current path) in a Nautilus browser window results in a black rectangle being drawn around that button, which does not disappear when the icon is moved away. It persists until the contents of the breadcrumbs changes.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.5.0-4.fc10.x86_64 on Intel X3100 hardware
nautilus-2.24.2-2.fc10.x86_64

How reproducible:
Always.
Comment 1 James Ettle 2009-04-11 06:46:12 EDT
Still present in nautilus-2.26.1-2.fc11.x86_64.
Comment 2 James Ettle 2009-04-11 06:48:11 EDT
Changing component to the intel driver, since I don't observe it on my ATI box.
Comment 3 Matěj Cepl 2009-07-24 03:00:43 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Matěj Cepl 2009-07-24 03:01:34 EDT
Sorry, could we get also some screenshot of the described behavior, please? It would probably be much more clear to us what kind of problem this is.
Comment 5 Matěj Cepl 2009-07-24 03:03:06 EDT
And if this is really xorg-x11-drv-intel problem (which I am still not persuaded to be) it could have some links to bug 509495
Comment 6 James Ettle 2009-07-24 03:14:43 EDT
Created attachment 354984 [details]
Xorg.0.log
Comment 7 James Ettle 2009-07-24 03:15:20 EDT
Created attachment 354985 [details]
a dmesg
Comment 8 James Ettle 2009-07-24 03:17:07 EDT
Created attachment 354986 [details]
Screenshot of the problem
Comment 9 James Ettle 2009-07-24 03:17:44 EDT
No xorg.conf is present.
Comment 10 Matěj Cepl 2009-07-24 09:16:35 EDT
(In reply to comment #8)
> Created an attachment (id=354986) [details]
> Screenshot of the problem  

This is IMHO almost certainly GTK2 problem.
Comment 11 Matthias Clasen 2009-07-24 12:05:09 EDT
Filed upstream here: http://bugzilla.gnome.org/show_bug.cgi?id=589621
Comment 12 James Ettle 2009-08-15 17:34:07 EDT
(In reply to comment #11)
> Filed upstream here: http://bugzilla.gnome.org/show_bug.cgi?id=589621  

Any chance of a backport of the fix?
Comment 13 Matthias Clasen 2009-08-15 19:23:36 EDT
No, this was fixed as a side-effect of completely replacing the rendering backend in gdk. Not something that can be backported...
Comment 14 James Ettle 2009-10-22 08:57:57 EDT
Still present in:

gtk2-2.18.3-4.fc12.x86_64
gtk2-2.18.3-4.fc12.i686
nautilus-2.28.0-3.fc12.x86_64
xorg-x11-drv-intel-2.9.0-2.fc12.x86_64
Comment 15 Matthias Clasen 2009-10-22 10:34:19 EDT
It doesn't reproduce here, with the same versions, unfortunately.
What theme are you using ?
Comment 16 James Ettle 2009-10-22 10:50:45 EDT
Glossy, but I still see it with Clearlooks and Nodoka. I've just updated the machine from F11, are there any package names to check for left-over .fc11 versions?
Comment 17 James Ettle 2009-10-23 05:43:30 EDT
Just pulled in another load of updates, and somewhere along the line it got fixed, so I'll close it RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.