Bug 48095 - shlib-with-non-pic-code /usr/lib/liblber40.so
shlib-with-non-pic-code /usr/lib/liblber40.so
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-09 13:46 EDT by Christopher Blizzard
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-24 12:32:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Blizzard 2001-07-09 13:46:51 EDT
Description of Problem:

rpmlint warning

E: mozilla-mail shlib-with-non-pic-code /usr/lib/liblber40.so
Comment 1 Christopher Blizzard 2001-07-24 12:32:07 EDT
From dmose:

There's definitely something odd going on here.  I looked at rpmlint, and it's
getting upset because

objdump --headers --private-headers -T liblber40.so | grep .rel

shows a .rel.data section.  After rebuilding on my local disk, it no longer
does.  So maybe it's some old makefile or tools bug that has since been fixed. 
 What happens if you do

make clean
make

in

directory/c-sdk/ldap/libraries

?  Does the objdump above still show the same issue?

Dan
Comment 2 Christopher Blizzard 2002-08-29 16:59:16 EDT
We don't even ship this library anymore.

Note You need to log in before you can comment on or make changes to this bug.