Bug 48095 - shlib-with-non-pic-code /usr/lib/liblber40.so
Summary: shlib-with-non-pic-code /usr/lib/liblber40.so
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mozilla   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-09 17:46 UTC by Christopher Blizzard
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-24 16:32:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher Blizzard 2001-07-09 17:46:51 UTC
Description of Problem:

rpmlint warning

E: mozilla-mail shlib-with-non-pic-code /usr/lib/liblber40.so

Comment 1 Christopher Blizzard 2001-07-24 16:32:07 UTC
From dmose:

There's definitely something odd going on here.  I looked at rpmlint, and it's
getting upset because

objdump --headers --private-headers -T liblber40.so | grep .rel

shows a .rel.data section.  After rebuilding on my local disk, it no longer
does.  So maybe it's some old makefile or tools bug that has since been fixed. 
 What happens if you do

make clean
make

in

directory/c-sdk/ldap/libraries

?  Does the objdump above still show the same issue?

Dan


Comment 2 Christopher Blizzard 2002-08-29 20:59:16 UTC
We don't even ship this library anymore.


Note You need to log in before you can comment on or make changes to this bug.