Bug 480979 - Eclipse JDT can't find javac for ant build
Eclipse JDT can't find javac for ant build
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 10:44 EST by Ben Konrath
Modified: 2009-01-26 10:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-26 10:06:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Konrath 2009-01-21 10:44:40 EST
Description of problem:

Eclipse JDT can't find javac for ant build.

Version-Release number of selected component (if applicable):

eclipse-jdt-3.4.1-5.fc10.i386

How reproducible:

Always

Steps to Reproduce:
1. Install eclispe-jdt
2. Import a Java project that has an ant build file
3. Try to run the ant build
  
Actual results:

Buildfile: /home/ben/workspace/mkgmap/build.xml
prepare:
compile:
    [javac] Compiling 254 source files to /home/ben/workspace/mkgmap/build/classes

BUILD FAILED
/home/ben/workspace/mkgmap/build.xml:46: Unable to find a javac compiler;
com.sun.tools.javac.Main is not on the classpath.
Perhaps JAVA_HOME does not point to the JDK.
It is currently set to "/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre"

Total time: 591 milliseconds

Expected results:

The JDT should find javac.

Additional info:

After installing java-1.6.0-openjdk-devel the ant build worked. Perhaps eclipse-jdt should require java-1.6.0-openjdk-devel.
Comment 1 Andrew Overholt 2009-01-23 10:34:08 EST
Yeah, we should definitely make JDT require the -devel package.  I can't believe we've gone this long without it!  Maybe it got removed accidentally.

I'll fix this right now.
Comment 2 Ben Konrath 2009-01-23 10:58:53 EST
Thanks Andrew! Cheers, Ben
Comment 3 Andrew Overholt 2009-01-26 10:06:58 EST
I built this in rawhide the other day:

Task ID:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1076751

RPMs can be downloaded from here:

http://kojipkgs.fedoraproject.org/packages/eclipse/3.4.1/14.fc11/

I'll probably wait until we have a higher priority issue to push an update to Fedora 10.  Is that okay with you, Ben?  I'll close this with resolution "rawhide" for now.
Comment 4 Ben Konrath 2009-01-26 10:56:15 EST
(In reply to comment #3)
> I'll probably wait until we have a higher priority issue to push an update to
> Fedora 10.  Is that okay with you, Ben?  I'll close this with resolution
> "rawhide" for now.

Since there is an easy fix, your plan seems good. Cheers, Ben

Note You need to log in before you can comment on or make changes to this bug.