Bug 481008 - Access to /net/fenlason-desk/local stopped working.
Access to /net/fenlason-desk/local stopped working.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 12:56 EST by Jay Fenlason
Modified: 2014-08-31 19:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 16:58:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/auto.master (605 bytes, text/plain)
2009-01-21 13:56 EST, Jay Fenlason
no flags Details
/etc/auto.net (1.21 KB, text/plain)
2009-01-21 13:56 EST, Jay Fenlason
no flags Details
/etc/nsswitch.conf (1.68 KB, text/plain)
2009-01-21 13:57 EST, Jay Fenlason
no flags Details
/etc/sysconfig/autofs (2.64 KB, text/plain)
2009-01-21 13:57 EST, Jay Fenlason
no flags Details
/var/log/debug (10.48 KB, text/plain)
2009-01-21 14:07 EST, Jay Fenlason
no flags Details
clear the quoted flag after each character is processed (400 bytes, patch)
2009-01-21 15:03 EST, Jeff Moyer
no flags Details | Diff

  None (edit)
Description Jay Fenlason 2009-01-21 12:56:57 EST
Description of problem:
fenlason-desk exports two directories: /local and /mnt/local.  When I ls /net/fenlason-desk, autofs mounts /mnt/local there, and does not allow me to access /net/fenlason-desk/local.

Version-Release number of selected component (if applicable):
autofs-5.0.4-5.i386

How reproducible:
always

Steps to Reproduce:
1.ls /net/fenlason-desk/ on fenlason-lab1
2.
3.
  
Actual results:
home  lost+found  music  tmp

Expected results:
local mnt

Additional info:
Comment 1 Jeff Moyer 2009-01-21 13:31:46 EST
Please see: http://people.redhat.com/jmoyer and include as much of the requested debug information as possible.

Thanks!
Comment 2 Jay Fenlason 2009-01-21 13:56:21 EST
Created attachment 329633 [details]
/etc/auto.master
Comment 3 Jay Fenlason 2009-01-21 13:56:47 EST
Created attachment 329634 [details]
/etc/auto.net
Comment 4 Jay Fenlason 2009-01-21 13:57:24 EST
Created attachment 329635 [details]
/etc/nsswitch.conf
Comment 5 Jay Fenlason 2009-01-21 13:57:53 EST
Created attachment 329636 [details]
/etc/sysconfig/autofs
Comment 6 Jay Fenlason 2009-01-21 14:07:17 EST
Created attachment 329638 [details]
/var/log/debug
Comment 8 Jay Fenlason 2009-01-21 14:24:28 EST
Changing /etc/auto.master to say
/net    -hosts
hides this bug.  I'm keeping it open pending an actual diagnosis and fix.
Comment 9 Jeff Moyer 2009-01-21 14:32:29 EST
lookup_mount: lookup(program): fenlason-desk -> -fstype=nfs,hard,intr,nodev,nosuid  \#011\/\l\o\c\a\l\ \f\e\n\l\a\s\o\n\-\d\e\s\k\:\/\l\o\c\a\l\ \\ \#011\/\m\n\t\/\l\o\c\a\l\ \f\e\n\l\a\s\o\n\-\d\e\s\k\:\/\m\n\t\/\l\o\c\a\l 

Wow, what on Earth is going on there?  Ian, is this after incorporating your patch that changes from select to poll?  I wonder if that's mucked up program maps.

FWIW, here's the output from /etc/auto.net:

$ /etc/auto.net fenlason-desk
-fstype=nfs,hard,intr,nodev,nosuid \
        /local fenlason-desk:/local \
        /mnt/local fenlason-desk:/mnt/local
Comment 10 Jeff Moyer 2009-01-21 14:35:57 EST
It looks like the quoted flag is never cleared.
Comment 11 Jeff Moyer 2009-01-21 15:03:15 EST
Created attachment 329646 [details]
clear the quoted flag after each character is processed

This regression was introduced by autofs-5.0.4-fix-select-fd-limit.patch.  The fix is to clear the quoted flag after processing each character.  Or, at least I think that's the fix.  ;)  Jay has agreed to test this patch for us.
Comment 12 Jay Fenlason 2009-01-21 16:18:30 EST
Yes, the patch works.
Comment 13 Jeff Moyer 2009-01-21 16:58:11 EST
A fix for this has been committed and will appear in autofs versions 5.0.4-6 and later.
Comment 14 Ian Kent 2009-01-21 20:30:13 EST
(In reply to comment #11)
> Created an attachment (id=329646) [details]
> clear the quoted flag after each character is processed
> 
> This regression was introduced by autofs-5.0.4-fix-select-fd-limit.patch.  The
> fix is to clear the quoted flag after processing each character.  Or, at least
> I think that's the fix.  ;)  Jay has agreed to test this patch for us.

Good catch Jeff.
Committed upstream.
Ian

Note You need to log in before you can comment on or make changes to this bug.