Bug 481014 - hotplugged keyboard layout doesn't respect selection made at login
hotplugged keyboard layout doesn't respect selection made at login
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 13:24 EST by Michael Williamson
Modified: 2009-10-27 14:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 14:21:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (423.95 KB, application/octet-stream)
2009-03-23 16:37 EDT, James M. Leddy
no flags Details

  None (edit)
Description Michael Williamson 2009-01-21 13:24:30 EST
Description of problem:

Keyboard layout selected at GDM login screen is not respected if a keyboard is unplugged and plugged back in during a session.  (I discovered a had a keyboard with an electrical problem resulting in disconnects/connects).

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. select dvorak layout at login screen and log into user account
2. disconnect and reconnect keyboard
3. grumble at the resulting QWERTY (or whatever system default) layout
  
Actual results:
vdtnsaoh od.dok; ks ;t;kdm hdyafpke
keyboard reverts to system default.

Expected results:
keyboard layout choosen at login should be used.

Additional info:
Comment 1 Michael Williamson 2009-01-21 23:30:29 EST
Keyboard used was USB, by the way.
Comment 2 James M. Leddy 2009-02-06 15:03:57 EST
This is happening to me and while not a big deal, the resulting frustration is off the charts.

My theory is evdev,  I'll look into it if I have time.  The solution being to go into system->hardware->keyboard, click on the layouts tab, and make a selection, then redo the old selection.
Comment 3 James M. Leddy 2009-03-20 16:07:55 EDT
reassigning evdev
Comment 4 Matěj Cepl 2009-03-23 16:29:46 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 James M. Leddy 2009-03-23 16:37:32 EDT
Created attachment 336380 [details]
Xorg.0.log

I don't have an xorg.conf
Comment 6 Peter Hutterer 2009-03-23 19:25:59 EDT
This isn't an evdev bug - changing to gnome-settings-daemon. The device comes up with the system-default configuration (usually what's in /etc/sysconfig/keyboard). g-s-d needs to listen to device presence events (which I think it does in rawhide).
Comment 7 Bastien Nocera 2009-04-29 14:44:50 EDT
This is done in libxklavier for rawhide.

We could do it using the patch from:
http://bugzilla.gnome.org/show_bug.cgi?id=560821
but it looks pretty invasive
Comment 8 James M. Leddy 2009-04-29 14:52:04 EDT
(In reply to comment #7)
> This is done in libxklavier for rawhide.
> 
> We could do it using the patch from:
> http://bugzilla.gnome.org/show_bug.cgi?id=560821
> but it looks pretty invasive  

It looks like ~40 lines?  All additions.

So if I download libxklavier from rawhide this will work?
Comment 9 Bastien Nocera 2009-05-07 21:59:53 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > This is done in libxklavier for rawhide.
> > 
> > We could do it using the patch from:
> > http://bugzilla.gnome.org/show_bug.cgi?id=560821
> > but it looks pretty invasive  
> 
> It looks like ~40 lines?  All additions.

Invasive meaning that it could break some other stuff.

> So if I download libxklavier from rawhide this will work?  

It probably won't work with the rest of the stuff from F10, but you could probably test with an F11 live CD/usb key.
Comment 10 Thomas Fitzsimmons 2009-10-27 14:10:31 EDT
This has worked fine for me throughout Fedora 11.  It can probably be closed now.
Comment 11 James M. Leddy 2009-10-27 14:21:05 EDT
yeah, fixed in F11

Note You need to log in before you can comment on or make changes to this bug.