Bug 481039 - When the dellsysidplugin2 is enabled, yum and kpackagekit, etc. hang.
When the dellsysidplugin2 is enabled, yum and kpackagekit, etc. hang.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libsmbios (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael E Brown
Fedora Extras Quality Assurance
http://www.smolts.org/client/show/pub...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 16:13 EST by Jerry Amundson
Modified: 2009-02-06 14:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-06 14:23:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output dmidecode (18.42 KB, text/plain)
2009-01-22 10:26 EST, Jerry Amundson
no flags Details
Output of dmidecode (system is Thinkpad X200) (12.59 KB, text/plain)
2009-02-02 13:31 EST, Tom London
no flags Details
stdout from "LIBSMBIOS_C_DEBUG_OUTPUT_ALL=1 smbios-sys-info > stdout.txt 2> stderr.txt" (304 bytes, text/plain)
2009-02-03 19:38 EST, Tom London
no flags Details
stderr.txt (compressed) from "LIBSMBIOS_C_DEBUG_OUTPUT_ALL=1 smbios-sys-info > stdout.txt 2> stderr.txt" (568.72 KB, application/x-gzip)
2009-02-03 19:39 EST, Tom London
no flags Details
stderr.txt (opti755) (2.36 MB, text/plain)
2009-02-04 12:11 EST, Jerry Amundson
no flags Details
stdout.txt (opti755) (279 bytes, text/plain)
2009-02-04 12:11 EST, Jerry Amundson
no flags Details

  None (edit)
Description Jerry Amundson 2009-01-21 16:13:48 EST
Description of problem:
When the dellsysidplugin2 is enabled, yum and kpackagekit, etc. hang.

Version-Release number of selected component (if applicable):
smbios-utils-python-2.2.8-1.fc11.x86_64

How reproducible:
very.

Steps to Reproduce:
1. Run yum.
2.
3.
  
Actual results:
Hung process, cannot even kill -9 it.

Expected results:
Finished command.

Additional info:
Comment 1 Michael E Brown 2009-01-21 23:38:42 EST
Need some more details. What type of machine is this? Can you attach the output of /usr/sbin/smbios-sys-info?
Comment 2 Jerry Amundson 2009-01-22 00:46:18 EST
# smbios-sys-info
Libsmbios version:      2.2.8
Product Name:           OptiPlex 755
Vendor:                 Dell Inc.
BIOS Version:           A11
System ID:              0x0211

and then hangs.
Comment 3 Michael E Brown 2009-01-22 03:15:38 EST
Ok, that hang is likely the root cause. The next piece of info it is trying to gather is the Service Tag. The code in smbios-sys-info is using the python interface to libsmbios_c, just like the sysid plugin. I will comment out the sysid plugin service tag retrieval, since this tag isnt used right now, while I debug the hang. I'll upload a new version of libsmbios shortly with this fix.

Next thing, can you please run smbios-sys-info-lite? This should provide the same info, but directly uses the C interface to the library. This should narrow down if the bug is in the python or C code.

Also, can you please attach "dmidecode" output to the bug? I need to see if your service tag is set to something wierd.

Meanwhile, I will attempt to find an optiplex 755 around here to reproduce this on.
Comment 4 Jerry Amundson 2009-01-22 09:19:09 EST
[root@jerry-opti755 ~]# smbios-sys-info-lite 
Libsmbios:    2.2.8
System ID:    0x0211
Comment 5 Jerry Amundson 2009-01-22 10:26:09 EST
Created attachment 329718 [details]
output dmidecode
Comment 6 Matěj Cepl 2009-01-27 20:34:00 EST
There is nothing to triage here.

Switching to ASSIGNED so that developers have responsibility to do whatever they want to do with it.
Comment 7 Tom London 2009-02-02 13:31:36 EST
Created attachment 330660 [details]
Output of dmidecode (system is Thinkpad X200)

Not sure if this is the same issue, but I'm having problems running "yum" when the dellsysidplugin2 plugin is enabled.

See: https://bugzilla.redhat.com/show_bug.cgi?id=483264

Briefly, my system is Thinkpad X200. I get crashes running "yum info installed \*fc10\*" about 20% of the time.

Disabling the delsysidplugin2 "fixes this for me".

[root@tlondon ~]# smbios-sys-info-lite
Libsmbios:    2.2.8
Error getting the System ID:    unknown error.
Service Tag:  L3AAW2A
Express Service Code: 45911131858
Aset Tag:  No Asset Information
Product Name: 74585FU
BIOS Version: 6DET38WW (2.02 )
Vendor:       LENOVO
Is Dell:      0
[root@tlondon ~]# smbios-sys-info
Libsmbios version:      2.2.8
Product Name:           74585FU
Vendor:                 LENOVO
BIOS Version:           6DET38WW (2.02 )
System ID:              0x0000
Service Tag:            L3AAW2A
Express Service Code:   45911131858
Asset Tag:              No Asset Information
Property Ownership Tag: 
[root@tlondon ~]# 

Attaching output of "dmidecode".
Comment 8 Michael E Brown 2009-02-03 14:15:51 EST
Jerry,
  I have not fixed the root cause of the hang, but I believe that I have fixed the yum hang.

  Libsmbios was hanging in the service tag function. This data isnt used by the yum plugin, so I commented out the parts of the plugin that retrieve service tag.

  Can you please check with the latest libsmbios copy to see if it fixes your yum hang with the plugin enabled?

Tom,
  I dont see specifically anything that could cause your hang, so I'm not sure how to go about debugging. Can you please check to see if the latest version fixes things for you?
Comment 9 Tom London 2009-02-03 14:35:38 EST
Latest update fixes segfaulting.....  (it wasn't hanging, just randomly segfaulting).

Running

for i in {1..100}; do echo $i; yum list installed \*fc10\* >/dev/null; done

now works (i.e., produces no segfaults/core dumps).  Previously, crashed/segfaulted about 20% (1 in 5) runs.

Must be common issue to hang.....

Thanks.
Comment 10 Jerry Amundson 2009-02-03 15:08:49 EST
I've confirmed that, with libsmbios-2.2.12-1 installed, yum etc. no longer hang my Dell Optiplex 755.
Comment 11 Michael E Brown 2009-02-03 16:46:41 EST
Thanks, Jerry.

I'm readying a libsmbios 2.2.13 release that has optional debugging output controlled by an environment variable, to try to find the root cause of the smbios-sys-info hang.

Can you please install 2.2.13 when it is finished building and run (as root):

#  LIBSMBIOS_C_DEBUG_OUTPUT_ALL=1 smbios-sys-info  > stdout.txt 2> stderr.txt

Then attach both text output files to this defect?
Comment 12 Tom London 2009-02-03 19:38:14 EST
Created attachment 330803 [details]
stdout from "LIBSMBIOS_C_DEBUG_OUTPUT_ALL=1 smbios-sys-info  > stdout.txt 2> stderr.txt"

Not sure if you wanted this from me, but just in case.

This is stdout.txt from "LIBSMBIOS_C_DEBUG_OUTPUT_ALL=1 smbios-sys-info  > stdout.txt 2> stderr.txt"
Comment 13 Tom London 2009-02-03 19:39:25 EST
Created attachment 330804 [details]
stderr.txt (compressed) from "LIBSMBIOS_C_DEBUG_OUTPUT_ALL=1 smbios-sys-info  > stdout.txt 2> stderr.txt"

stderr.txt was pretty big, so I gziped it.
Comment 14 Jerry Amundson 2009-02-04 12:11:01 EST
Created attachment 330888 [details]
stderr.txt (opti755)
Comment 15 Jerry Amundson 2009-02-04 12:11:56 EST
Created attachment 330889 [details]
stdout.txt (opti755)
Comment 16 Michael E Brown 2009-02-04 12:37:20 EST
Thanks for the debugging output. smbios-sys-info doesnt appear to be hanging anymore, and I dont see any clues in the debugging logs that would indicate when/where/why it would hang. Looking through my git logs, I dont see any fixes that would fix something like this (unless I'm just missing it).

Can you run the command in a loop to see if it crashes at all with repeated runs? This should do it:

LIBSMBIOS_C_DEBUG_OUTPUT_ALL=1 watch -n 0.1 'smbios-sys-info 2>stderr.txt'

Then, if you see it hang with partial output, you can copy stderr.txt. This should tell me where it is hanging.

I've run this loop on my laptop for a while now with no hangs, so I am not apparently seeing this hang.
Comment 17 Michael E Brown 2009-02-04 12:46:41 EST
One idea. The last segfault that I fixed was in version 2.2.7 and only happened if the "dcdbas" kernel module was not installed.

Can you check lsmod to see if dcdbas is loaded? If not, try 'modprobe dcdbas' to see if the problem goes away. If that is it, then I should be able to fix the segfault. (I've tested locally, and dellWirelessCtl works for me with dcdbas loaded, and gives a reasonable error message if dcdbas is not loaded.)

Regardless of the above, the following should help me track down the error if it is still segfaulting:

LIBSMBIOS_C_DEBUG_OUTPUT_ALL=1 dellWirelessCtl --st_wlan > stdout.txt 2>stderr.txt

Thanks
Comment 18 Michael E Brown 2009-02-04 12:47:53 EST
oops. copied comment #17 into the wrong bug. It should have been attached to BZ# 481453.
Comment 19 Michael E Brown 2009-02-06 14:23:29 EST
closing this bug as it appears to have been fixed.

Note You need to log in before you can comment on or make changes to this bug.