This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 481048 - PUP/pirut Bug?
PUP/pirut Bug?
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: James Antill
desktop-bugs@redhat.com
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 16:59 EST by Will Bancks
Modified: 2013-03-12 16:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 16:26:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Dump from PUP (3.06 KB, text/plain)
2009-01-21 16:59 EST, Will Bancks
no flags Details

  None (edit)
Description Will Bancks 2009-01-21 16:59:37 EST
Created attachment 329666 [details]
Dump from PUP

Description of problem:
PUP blew up with an unexpected exception & told me to send this dump to bugzilla.

Version-Release number of selected component (if applicable):
pirut-1.3.28-13.el5

How reproducible:
It has happened to me once, so far.

Steps to Reproduce:
1. Ran PUP & Selected some packages to update.
2. Pressed Apply Updates & the fatal exception came up almost immediately.
3. Told me to send this dump to bugzilla, since it was very likely a bug.
  
Actual results:


Expected results:


Additional info:
Comment 1 James Antill 2009-04-29 12:08:33 EDT
 This is just a weird network error:

  File "/usr/lib/python2.4/site-packages/M2Crypto/SSL/Connection.py", line 149, in connect_ssl
    return m2.ssl_connect(self.ssl, self._timeout)
SSLError: (104, 'Connection reset by peer')

...shouldn't happen.
Comment 2 Cameron Meadors 2009-04-29 14:37:19 EDT
Reopening.  Network errors should not crash pirut.  The errors should at least be caught and exit with a error message in plain language.
Comment 3 James Antill 2013-03-12 16:26:36 EDT
This request was evaluated by Red Hat Engineering for inclusion in a Red 
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat 
Enterprise Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in 
response to customer and partner requirements, Red Hat takes a 
conservative approach when evaluating enhancements for inclusion in 
maintenance updates for currently deployed products. The primary 
objectives of update releases are to enable new hardware platform 
support and to resolve critical defects.

Note You need to log in before you can comment on or make changes to this bug.