Bug 481053 - unhandled indexerror while updating
unhandled indexerror while updating
Status: CLOSED DUPLICATE of bug 441738
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Pradeep Kilambi
Red Hat Satellite QA List
:
: 503682 503904 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 17:16 EST by Brent Holden
Modified: 2009-06-10 08:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 08:52:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
IndexError traceback from rhnplugin.py (4.76 KB, text/plain)
2009-01-21 17:17 EST, Brent Holden
no flags Details

  None (edit)
Description Brent Holden 2009-01-21 17:16:19 EST
Description of problem:

RHN plugin randomly does not correctly handle a system update.  Yum will error after RPM has cleaned up installation of packages.

Version-Release number of selected component (if applicable):
RHEL 5.3
yum 3.2.19-18
yum-rhn-plugin 0.5.3-30

How reproducible:

Appears at random

  
Actual results:

See attachment


Expected results:

A handled IndexError exception
Comment 1 Brent Holden 2009-01-21 17:17:49 EST
Created attachment 329667 [details]
IndexError traceback from rhnplugin.py
Comment 2 John Matthews 2009-01-21 17:30:36 EST
It looks like this is related to a problem with SSL communication.

rhnplugin caught an OpenSSL.SSL.Error, then it hit a bug while trying to reformat the exception. 

we have a bug in our code, here rhnplugin.py: line 61-62
if len(pieces) >= 2:
    message = pieces[2].strip(" '")

Should be:
if len(pieces) > 2:
    message = pieces[2].strip(" '")
Comment 5 Pradeep Kilambi 2009-06-02 10:20:27 EDT
*** Bug 503682 has been marked as a duplicate of this bug. ***
Comment 6 Jan Hutař 2009-06-03 06:25:50 EDT
*** Bug 503904 has been marked as a duplicate of this bug. ***
Comment 7 Jan Hutař 2009-06-10 05:43:01 EDT
This looks like an duplicate of bug 441738. Can you please confirm?
Comment 8 Pradeep Kilambi 2009-06-10 08:52:26 EDT
yea looks like it.

*** This bug has been marked as a duplicate of bug 441738 ***

Note You need to log in before you can comment on or make changes to this bug.